This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 43644

Summary: Poor naming scheme: addPathRegistryListener(GlobalPathRegistryListener)
Product: java Reporter: Jesse Glick <jglick>
Component: UnsupportedAssignee: Jesse Glick <jglick>
Severity: blocker CC: mmatula
Priority: P3 Keywords: API
Version: 4.x   
Hardware: All   
OS: All   
Issue Type: DEFECT Exception Reporter:
Bug Depends on:    
Bug Blocks: 41535    

Description Jesse Glick 2004-05-20 18:47:16 UTC
I will change the methods
add/removePathRegistryListener in
GlobalPathRegistry to be
add/removeGlobalPathRegistryListener. Not just
cosmetic: if you don't use the special 4-arg form
of WeakListeners.create, you get a memory leak. I
wouldn't expect most users of the API to notice
this, and in fact it seems that the refactoring
build contained this error; WeakListeners prints a
warning to that effect on console. So will just
change the name to a safer form that should work
correctly with the 3-arg variant of WL.c.
Comment 1 Jesse Glick 2004-05-20 18:48:43 UTC
committed   * Up-To-Date  1.4        
committed   * Up-To-Date  1.4        
committed   * Up-To-Date  1.4