This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 43870

Summary: NPE while opening file in editor
Product: projects Reporter: pfelenda <pfelenda>
Component: Generic InfrastructureAssignee: Petr Hrebejk <phrebejk>
Status: CLOSED FIXED    
Severity: blocker Keywords: REGRESSION
Priority: P2    
Version: 4.x   
Hardware: All   
OS: All   
Issue Type: DEFECT Exception Reporter:
Bug Depends on:    
Bug Blocks: 41535    
Attachments: Exception

Description pfelenda 2004-05-26 12:36:19 UTC
refactoring [040525], jdk1.4.2_03
Comment 1 pfelenda 2004-05-26 12:37:05 UTC
Created attachment 15149 [details]
Exception
Comment 2 pfelenda 2004-05-26 12:38:00 UTC
Part of exception : 

java.lang.NullPointerException
	at
org.netbeans.modules.project.ui.OpenProjectList.updateTemplatesLRU(OpenProjectList.java:260)
	at
org.netbeans.modules.project.ui.actions.NewFile.doPerform(NewFile.java:134)
Comment 3 Tomas Hurka 2004-05-27 16:23:11 UTC
It looks to me like general projects issue, which has nothing to do with refactoring. 
Comment 4 Jesse Glick 2004-05-27 16:41:57 UTC
Seems to happen to other people too.
Comment 5 Jesse Glick 2004-05-27 16:42:18 UTC
*** Issue 43931 has been marked as a duplicate of this issue. ***
Comment 6 Petr Hrebejk 2004-05-31 14:09:15 UTC
Checking in
projects/projectui/src/org/netbeans/modules/project/ui/OpenProjectList.java;
/cvs/projects/projectui/src/org/netbeans/modules/project/ui/OpenProjectList.java,v
 <--  OpenProjectList.java
new revision: 1.14; previous revision: 1.13
done
Checking in
projects/projectui/src/org/netbeans/modules/project/ui/OpenProjectListSettings.java;
/cvs/projects/projectui/src/org/netbeans/modules/project/ui/OpenProjectListSettings.java,v
 <--  OpenProjectListSettings.java
new revision: 1.7; previous revision: 1.6
done
Comment 7 dmladek 2004-07-30 13:22:56 UTC
I would say it is fixed in recent DEV (4.0) builds