This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 46343

Summary: Project actions eagerly set name on lookup changes
Product: projects Reporter: _ rkubacki <rkubacki>
Component: Generic Projects UIAssignee: Petr Hrebejk <phrebejk>
Status: CLOSED FIXED    
Severity: blocker CC: issues
Priority: P4 Keywords: PERFORMANCE
Version: 4.x   
Hardware: All   
OS: All   
Issue Type: DEFECT Exception Reporter:
Bug Depends on:    
Bug Blocks: 41535    

Description _ rkubacki 2004-07-20 15:36:45 UTC
Most of actions in projects/ui calls setName in
refresh method. This is probably too agresive way
as the lookup is changed more often than action is
shown. For example there is no reason to update
action name during file editing when
TopComponent.setActivatedNodes is called.
Comment 1 Petr Hrebejk 2004-09-29 16:56:14 UTC
Now the actions only refresh when some listener is attached to it or
when there was a change in the associated Lookup and someone cals
either getValue() or isEnabled on the action. 

However some SystemActions wrappers still attach unneeded listeners to
the project actions. Will try t fix it soon. Please reffer to issue
#43084 and issue #48765 for more info. 


Checking in
projectui/src/org/netbeans/modules/project/ui/actions/FileCommandAction.java;
/cvs/projects/projectui/src/org/netbeans/modules/project/ui/actions/FileCommandAction.java,v
 <--  FileCommandAction.java
new revision: 1.7; previous revision: 1.6
done
Checking in
projectui/src/org/netbeans/modules/project/ui/actions/LookupSensitiveAction.java;
/cvs/projects/projectui/src/org/netbeans/modules/project/ui/actions/LookupSensitiveAction.java,v
 <--  LookupSensitiveAction.java
new revision: 1.6; previous revision: 1.5
done
Checking in
projectui/src/org/netbeans/modules/project/ui/actions/ProjectAction.java;
/cvs/projects/projectui/src/org/netbeans/modules/project/ui/actions/ProjectAction.java,v
 <--  ProjectAction.java
new revision: 1.4; previous revision: 1.3
done
Processing log script arguments...
More commits to come...
Checking in
projectui/test/unit/src/org/netbeans/modules/project/ui/actions/LookupSensitiveActionTest.java;
/cvs/projects/projectui/test/unit/src/org/netbeans/modules/project/ui/actions/LookupSensitiveActionTest.java,v
 <--  LookupSensitiveActionTest.java
new revision: 1.2; previous revision: 1.1
done
Checking in
projectui/test/unit/src/org/netbeans/modules/project/ui/actions/ProjectActionTest.java;
/cvs/projects/projectui/test/unit/src/org/netbeans/modules/project/ui/actions/ProjectActionTest.java,v
 <--  ProjectActionTest.java
new revision: 1.2; previous revision: 1.1
done
Processing log script arguments...
More commits to come...
Checking in
projectuiapi/src/org/netbeans/spi/project/ui/support/ProjectSensitiveActions.java;
/cvs/projects/projectuiapi/src/org/netbeans/spi/project/ui/support/ProjectSensitiveActions.java,v
 <--  ProjectSensitiveActions.java
new revision: 1.8; previous revision: 1.7
done
Comment 2 Marian Mirilovic 2005-12-20 15:47:37 UTC
This issue was solved long time ago. Because nobody has reopened it neither
added comments, we are verifying/closing it now. 
If you are still able to reproduce the problem, please reopen. Thanks in advance.