This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 48246

Summary: 2 default packages in 1 project
Product: java Reporter: Jaromir Uhrik <juhrik>
Component: ProjectAssignee: Tomas Zezula <tzezula>
Status: CLOSED FIXED    
Severity: blocker    
Priority: P3    
Version: 4.x   
Hardware: PC   
OS: Linux   
Issue Type: DEFECT Exception Reporter:
Bug Depends on:    
Bug Blocks: 41535    

Description Jaromir Uhrik 2004-08-31 15:24:12 UTC
[200408301800; jdk1.5.0-rc-b63]
1.Create projects prj1 and prj2
2.On the prj1/Source Packages/prj1/Main.java
invoke popup menu action Copy
3. On the prj1/Source Packages invoke popup menu
action Paste - the <default package> and Main.java
in it is created
4.Do similar steps 2. and 3. but for prj2
5.Press Copy on <default package> of prj1
6.Press Paste->Paste Package on the prj2/Source
Packages
7.Two default packages appear in the prj2
Comment 1 Petr Hrebejk 2004-09-01 11:40:34 UTC
Probably invalid as there should be only one paste action.
Comment 2 Tomas Zezula 2004-09-01 15:06:36 UTC
Don't think so, it happens even with one PasteType.
Comment 3 Tomas Zezula 2004-09-01 15:54:23 UTC
Checking in
project/src/org/netbeans/spi/java/project/support/ui/PackageViewChildren.java;
/cvs/java/project/src/org/netbeans/spi/java/project/support/ui/PackageViewChildren.java,v
 <--  PackageViewChildren.java
new revision: 1.35; previous revision: 1.34
done
Processing log script arguments...
More commits to come...
Checking in
project/test/unit/src/org/netbeans/spi/java/project/support/ui/PackageViewTest.java;
/cvs/java/project/test/unit/src/org/netbeans/spi/java/project/support/ui/PackageViewTest.java,v
 <--  PackageViewTest.java
new revision: 1.14; previous revision: 1.13
done
Comment 4 Tomas Zezula 2004-09-02 08:07:51 UTC
*** Issue 48238 has been marked as a duplicate of this issue. ***
Comment 5 Jaromir Uhrik 2004-09-02 09:52:14 UTC
Verified in 200409011800; jdk1.5.0-rc-b63.