This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 48379

Summary: [40cat] Adding components to library doesn't update build.properties
Product: projects Reporter: Milan Kubec <mkubec>
Component: LibrariesAssignee: Tomas Zezula <tzezula>
Status: CLOSED FIXED    
Severity: blocker    
Priority: P3    
Version: 4.x   
Hardware: All   
OS: All   
Issue Type: DEFECT Exception Reporter:
Bug Depends on:    
Bug Blocks: 41535    

Description Milan Kubec 2004-09-02 15:09:21 UTC
[custom 20040902, JDK 1.5.0 RC]

Steps to reproduce:
1) Add library to IDE and fill in only classpath
2) Close Library manager
Look into ${userdir}/build.properties - it
contains only library classpath
3) Open Library manager and fill in sources and/or
javadoc, close Lib. manager
4) Look into ${userdir}/build.properties - it
still contains only library classpath, other
components were not added.
After IDE restart build.properties contains all
library components.
Comment 1 Tomas Zezula 2004-09-02 16:08:35 UTC
*** Issue 48368 has been marked as a duplicate of this issue. ***
Comment 2 Milan Kubec 2004-09-03 07:56:34 UTC
#48368 has been filed as NetCAT issue.
Comment 3 Tomas Zezula 2004-09-05 10:15:57 UTC
Checking in org/netbeans/modules/project/libraries/LibrariesStorage.java;
/cvs/projects/libraries/src/org/netbeans/modules/project/libraries/LibrariesStorage.java,v
 <--  LibrariesStorage.java
new revision: 1.12; previous revision: 1.11
done
Comment 4 Milan Kubec 2004-09-07 09:49:35 UTC
Well, described problem is fixed but there is another one. Once you
start removing library components the file build.properties is not
updated and still contains removed entries. But this is more serious,
because it's not fixed by IDE restart.
Comment 5 Tomas Zezula 2004-09-07 10:45:50 UTC
Sorry it was my bug, I didn't try the content removal.
I am working on the unit test for the LibrariesStorage. This will make
the libraries framework easier to test. I am going to commit it today.

Checking in
j2seplatform/src/org/netbeans/modules/java/j2seplatform/libraries/J2SELibraryTypeProvider.java;
/cvs/java/j2seplatform/src/org/netbeans/modules/java/j2seplatform/libraries/J2SELibraryTypeProvider.java,v
 <--  J2SELibraryTypeProvider.java
new revision: 1.11; previous revision: 1.10
done
Comment 6 Milan Kubec 2004-09-08 10:51:03 UTC
Verified in dev-200409071800.