This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 52960

Summary: Rename/Move class should refactor appropriate Test class
Product: java Reporter: zikmund <zikmund>
Component: JUnitAssignee: Theofanis Oikonomou <theofanis>
Status: RESOLVED FIXED    
Severity: blocker CC: ceklock, jglick, jrcbriggs, pribyl
Priority: P2    
Version: 4.x   
Hardware: PC   
OS: All   
Issue Type: ENHANCEMENT Exception Reporter:

Description zikmund 2005-01-05 10:30:30 UTC
Refactoring on rename/move class in sources should
offer rename/move of appropriate JUnit test class.
Comment 1 Ondrej Rypacek 2005-01-14 10:47:46 UTC
good idea
Comment 2 pribyl 2008-04-30 16:46:47 UTC
*** Issue 62724 has been marked as a duplicate of this issue. ***
Comment 3 pribyl 2008-04-30 16:48:16 UTC
*** Issue 62897 has been marked as a duplicate of this issue. ***
Comment 4 Jesse Glick 2008-04-30 19:18:33 UTC
Issue #62897 was actually slightly different: dealing with renames of methods, not classes. Of course having both would
be nice.
Comment 5 pribyl 2008-04-30 19:29:03 UTC
Oops, sorry, my bad. I see it now.

Should I, well, "unduplicate" it? :) Or can we take this as global 'refactoring-of-JUnit-tests' thing?
Comment 6 Jesse Glick 2008-04-30 19:32:32 UTC
I think it's fine to take this to include refactoring of both the tested class and methods in it. Very related.
Comment 7 jrcbriggs 2011-07-21 08:31:56 UTC
Rename/Move method should refactor appropriate Test method.
See 62897 closed a duplicate.
Comment 8 Antonin Nebuzelsky 2011-10-17 11:34:40 UTC
*** Bug 203788 has been marked as a duplicate of this bug. ***
Comment 9 Theofanis Oikonomou 2013-01-29 16:34:36 UTC
The refactoring works when a class is renamed. Implemented in http://hg.netbeans.org/main-golden/rev/0a625e9c83a5. So closing this one and I will reopen bug 62897 which is about methods refactoring. Thank you