This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 56302

Summary: NetBeans may hang with "Enable access for assistive devices" on
Product: platform Reporter: Jan Chalupa <jchalupa>
Component: -- Other --Assignee: issues@platform <issues>
Status: RESOLVED WONTFIX    
Severity: blocker CC: pkeegan, tmulligan
Priority: P2 Keywords: RELNOTE
Version: 4.x   
Hardware: Macintosh   
OS: Mac OS X   
Issue Type: DEFECT Exception Reporter:

Description Jan Chalupa 2005-03-11 22:06:16 UTC
A Mac user reported:

"Has anyone gotten the NetBeans 4.1 Beta to run successfully on OS X (version
10.3.8)?  I just downloaded it today from netbeans.org, and it hangs every time
after opening the main window, it chews up all available CPU time and allocates
more and more real memory until there is no more."

... and later pointed out the cause:

"It turns out that NetBeans 4.1 only hangs on startup if the "Enable access for
assistive devices" is turned on in the Universal Access System Preferences
screen.  This is off by default, I had turned it on to enable a feature in
DragThing I wanted to use.  But I'll have to live without that, at least until
Apple fixes the JVM."

There is nothing to be done in the NetBeans code, but this issue should be
release noted.
Comment 1 Jan Chalupa 2005-03-11 22:07:00 UTC
Adding RELNOTE keyword.
Comment 2 Patrick Keegan 2005-03-14 21:25:40 UTC
This seems like a somewhat marginal thing to be release noted (at least with our
current approach where we try to keep it to "top 10" issues), though I grant the
severity, which IMO is more like P1. How many Mac users are likely to mess with
the assistive technologies section?

Another idea might be to put this info in an FAQ with Mac-specific issues,
something like an updated version of http://www.netbeans.org/kb/articles/mac.html
Comment 3 Jan Chalupa 2005-03-14 21:29:32 UTC
Re "How many": don't know. I've seen too independent reports just recently.

Re "Mac specific doc": sounds good to me.
Comment 4 Patrick Keegan 2005-03-14 21:33:06 UTC
RE: 2 recent independent reports, let's monitor it. If it turns out that there
are popular Mac apps that require this setting, maybe it is frequent enough.

Also, we're not committing to owning a Mac-specific doc, but we could contribute
to anything that already exists, though Tomas Hurka's current one seems out of date.