This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 58176

Summary: WrapperBookmarkAction should not extend NodeAction
Product: editor Reporter: _ rkubacki <rkubacki>
Component: -- Other --Assignee: issues@editor <issues>
Status: RESOLVED DUPLICATE    
Severity: blocker CC: issues
Priority: P3 Keywords: PERFORMANCE
Version: 4.x   
Hardware: All   
OS: All   
Issue Type: DEFECT Exception Reporter:

Description _ rkubacki 2005-04-21 16:00:45 UTC
It is a mistake to extend NodeAction and override enable() to always return
true. The NodeAction is expensive as it listens to changes of activated nodes. 

Maybe we do not need to extend SystemAction in Bookmarks module at all to avoid
too many classes here - Next/Prev/Toggle.
Comment 1 Miloslav Metelka 2005-05-04 09:53:06 UTC
I plan to use regular editor actions for the bookmarks actions. I just could not
do that yet as the editor did not allow to register actions from external
modules but it's planned to be implemented.
Comment 2 Miloslav Metelka 2007-01-02 14:28:07 UTC
The change is not yet performed and not sure whether we'll fix it for 6.0.
Comment 3 Jan Becicka 2008-02-15 08:33:21 UTC

*** This issue has been marked as a duplicate of 85442 ***