This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 58221

Summary: Cannot generate javadoc in 4.1 for project created in 4.0
Product: java Reporter: Milan Kubec <mkubec>
Component: ProjectAssignee: Tomas Zezula <tzezula>
Status: CLOSED FIXED    
Severity: blocker Keywords: RELNOTE
Priority: P2    
Version: 4.x   
Hardware: All   
OS: All   
Issue Type: DEFECT Exception Reporter:
Bug Depends on:    
Bug Blocks: 58222    

Description Milan Kubec 2005-04-22 13:07:18 UTC
[release41-200504200735, JDK1.5.0_03]

Steps to reproduce:
1) Create project in NB 4.0
2) Open the project in 4.1, change some its property to upgrade the project to 4.1
3) Generate javadoc for the project
You get error message:
javadoc: error - Illegal package name: "${javadoc.additionalparam}"

Generation of javadoc fails. The workaround is to create property
javadoc.additionalparam in project.properties file by hand.

It should be probably P1, but there is easy workaround, but the impression is
quite bad because after opening project from previos version user cannot
generated javadoc for the project without manual editing the file.
Comment 1 zikmund 2005-04-22 13:24:47 UTC
Release note should mention all 4.0 projects (Web and Java) - see issue 58222
for more information.
Comment 2 Tomas Zezula 2005-04-25 13:47:04 UTC
Checking in j2seproject/src/org/netbeans/modules/java/j2seproject/UpdateHelper.java;
/cvs/java/j2seproject/src/org/netbeans/modules/java/j2seproject/UpdateHelper.java,v
 <--  UpdateHelper.java
new revision: 1.11; previous revision: 1.10
done
Comment 4 Milan Kubec 2005-06-30 09:10:01 UTC
Verified in dev-200506291800.