This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 72324

Summary: Hanging progress handle
Product: utilities Reporter: _ rkubacki <rkubacki>
Component: SearchAssignee: Marian Petras <mpetras>
Status: RESOLVED FIXED    
Severity: blocker Keywords: SIMPLEFIX
Priority: P3    
Version: 6.x   
Hardware: All   
OS: All   
Issue Type: DEFECT Exception Reporter:

Description _ rkubacki 2006-02-06 22:43:47 UTC
dev build from Jan 20, JDK 1.6.0_b68

Sometimes after search in files action (performed from explorer) the progress
remains visible although the search is finished (showing indeterminate
progress). There is no way how to remove it (it cannot be cancelled).
Comment 1 Marian Petras 2006-07-11 12:19:03 UTC
Accepted.
Comment 2 Marian Petras 2006-07-11 12:19:38 UTC
*** Issue 72756 has been marked as a duplicate of this issue. ***
Comment 3 Marian Petras 2006-07-11 12:21:05 UTC
This should be fixed by a small modification of method SearchTask.run().
Comment 4 Marian Petras 2007-02-16 17:17:56 UTC
*** Issue 84116 has been marked as a duplicate of this issue. ***
Comment 5 Marian Petras 2007-02-16 17:18:19 UTC
*** Issue 94962 has been marked as a duplicate of this issue. ***
Comment 6 Marian Petras 2007-02-16 17:21:27 UTC
Fixed in the trunk.

Modified file:
   utilities/src/org/netbeans/modules/search/SearchTask.java   (1.18)

Diff:
http://utilities.netbeans.org/source/browse/utilities/src/org/netbeans/modules/search/SearchTask.java?r1=1.17&r2=1.18&diff_format=u