This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 78339

Summary: Stereotypes aren't shown on diagram for attributes/operations in platform independent model
Product: uml Reporter: bugbridge <bugbridge>
Component: General DiagramAssignee: issues@uml <issues>
Status: RESOLVED DUPLICATE    
Severity: blocker CC: sj-nb
Priority: P2    
Version: 5.x   
Hardware: PC   
OS: Windows XP   
Issue Type: ENHANCEMENT Exception Reporter:

Description bugbridge 2006-06-19 21:59:54 UTC
Original status: 5-Cause Known; Suggested Status: NEW


Description:
reproducible with coke build 060417

steps to reproduce:
1. create platform independent project
2. add class diagram
3. add class to the diagram
4. add attribute to the class
5. select the attribute
6. in properties add stereotype to the attribute
stereotype isn't shown on diagram

Evaluation:
This bug is not a show stopper for TPR3.  Investigating futher for the root cause.
Comment 1 Thuy.d Nguyen 2006-12-06 23:05:33 UTC
This issue is similar to issue 78647 but not exactly the same.  

In this case, the added stereotype is shown on  the properties but not  the
diagram element where as in the case of  issue 78647, the added stereotype is
not shown on either of locations.
Comment 2 Peter Lam 2007-03-20 23:20:05 UTC
low use case not currently impacting our installed user base.
Comment 3 George Vasick 2007-06-28 21:42:25 UTC
Targeted in the drawing area redesign.
Comment 4 George Vasick 2007-07-04 00:44:17 UTC
REstoring the original priority and using the NB 6.0 waiver process.
Comment 5 George Vasick 2008-01-02 16:54:35 UTC
Diagram area bugs waived for 6.0 will also be waived for 6.1.
Comment 6 Joanne Lau 2008-05-21 02:07:00 UTC
still exists in 6.5
Comment 7 George Vasick 2008-06-10 17:11:42 UTC
Removing obsolete assignments.  Bugs will be reassigned for M2.
Comment 8 George Vasick 2008-06-30 21:39:30 UTC
Enhancement after 6.5.
Comment 9 Peter Lam 2008-10-14 16:30:47 UTC

*** This issue has been marked as a duplicate of 82995 ***