This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 83248

Summary: NPE on comment autocompletion in my web.xml (docbook catalog)
Product: javaee Reporter: jmalonzo <jmalonzo>
Component: CodeAssignee: Erno Mononen <emononen>
Status: RESOLVED FIXED    
Severity: blocker CC: pjiricka, sherold
Priority: P3 Keywords: SIMPLEFIX
Version: 5.x   
Hardware: All   
OS: Linux   
Issue Type: DEFECT Exception Reporter:
Attachments: Issue 83248 stack trace

Description jmalonzo 2006-08-23 06:30:41 UTC
Version: Netbeans 5.5 daily (22 Aug 2006)
JDK version 1.5.0_7

Hi! After entering '<!' in my web.xml, a NPE occurred. To reproduce this error,
just remove and retype the said characters. t Stack trace attached.

Cheers.
Comment 1 jmalonzo 2006-08-23 06:33:04 UTC
Created attachment 33183 [details]
Issue 83248 stack trace
Comment 2 Jiri Kovalsky 2006-08-31 13:09:45 UTC
This looks like a problem in XML editor. Can you please Marku investigate what's
wrong here or reassign it to web/ddeditor ? Thank you.
Comment 3 Sherold Dev 2006-09-01 10:13:14 UTC
To reproduce this issue the DocBook XML module has to be installed e.g. from the
auto update.

The problem, however, seems to be that the 

org.netbeans.modules.j2ee.ddloaders.web.DDGrammarQueryManager

class violates the EntityResolver.resolveEntity() method contract by passing
null as a systemId parameter.

Reassigning to the j2ee component for further evaluation
Comment 4 Erno Mononen 2006-09-01 10:33:45 UTC
Should be quite simple fix, setting TM to 5.5.
Comment 5 Erno Mononen 2006-09-01 12:20:51 UTC
Fixed in release55 branch. Changed DDGrammarQuerManager to pass an empty string 
instead of null.

Checking in DDGrammarQueryManager.java;
/cvs/j2ee/ddloaders/src/org/netbeans/modules/j2ee/ddloaders/web/
DDGrammarQueryManager.java,v  <--  DDGrammarQueryManager.java
new revision: 1.1.22.1.2.3; previous revision: 1.1.22.1.2.2
done
Comment 6 _ ludo 2006-09-01 18:22:38 UTC
applied similar fix to AS plugin as well:
Checking in RunTimeDDCatalog.java;
/cvs/serverplugins/sun/appsrv81/src/org/netbeans/modules/j2ee/sun/ide/j2ee/RunTimeDDCatalog.java,v
 <--  RunTimeDDCatalog.java
new revision: 1.2.8.5.2.5; previous revision: 1.2.8.5.2.4