This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 94993

Summary: Certain configs not showing in Files window
Product: utilities Reporter: mclaassen <mclaassen>
Component: PropertiesAssignee: issues@utilities <issues>
Status: RESOLVED DUPLICATE    
Severity: blocker    
Priority: P3    
Version: 6.x   
Hardware: PC   
OS: Windows XP   
Issue Type: DEFECT Exception Reporter:

Description mclaassen 2007-02-08 17:22:24 UTC
Daily build 200702041900

Outside of NB, I created some configs.  There names are:

Builder.properties
Builder-1_5.properties
Builder_MAC.properties

I can select any of them from the run-configuration combo box (and they work),
but Builder_MAC.properties does not show up in the Files window.  I added a
parent directory to the Favorites window, and it doesn't show up there either.

I know it exists, since it shows up just find in the Windows explorer and, as I
stated earlier, it is selectable (and functional) in the run configuration combo
box.

This is not the first time I have noticed this kind of thing.  The first time I
thought it was just a fluke in M6.  Since it is still in the daily I got the
other day, and M7 is approaching, I thought I should report it.
Comment 1 mclaassen 2007-02-08 17:24:54 UTC
I renamed Builder_MAC.properties to Builder-MAC.properties and it appears in the
Files window after a few seconds.  If I change back to Builder_MAC.properties,
it disappears again in a few seconds.
Comment 2 Marian Petras 2007-02-12 15:34:00 UTC
The explanation of this phenomenon is simple - all .properties files named
<something>_<abbr>.properties are bundled together with <something>.properties
and displayed under one node named just <something>.properties. If you expand
that node, you will see the following subnodes representing individual files:

    default language
    MAC - mac

The idea of bundling multiple .properties files together was to make
internationalization/localization more intuitive by bundling related
localization files together. Later we found it was a bad design and a bug was
filed for it - see issue #42919 ("Poor UI of *.properties used for non-I18N
purposes"). It should be changed in the release following NetBeans 6.0.

*** This issue has been marked as a duplicate of 42919 ***
Comment 3 Marian Petras 2007-07-16 14:00:35 UTC
*** Issue 109542 has been marked as a duplicate of this issue. ***