This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 96068

Summary: NPE on invalid project.xml file
Product: apisupport Reporter: pzajac <pzajac>
Component: ProjectAssignee: Jesse Glick <jglick>
Status: RESOLVED DUPLICATE    
Severity: blocker    
Priority: P3    
Version: 6.x   
Hardware: All   
OS: All   
Issue Type: DEFECT Exception Reporter:

Description pzajac 2007-02-20 17:44:56 UTC
DON'T DELETE THIS TEXT:
http://anna.nbextras.org/exceptions/detail.do?id=134
Build: NetBeans IDE Dev (Build 200702162122)
VM: Java HotSpot(TM) Client VM, 1.6.0-b105
OS: Windows XP, 5.1, x86


Module.java:
Type is null:

        Element docel = doc.getDocumentElement();
        Element type = Util.findElement(docel, "type",
"http://www.netbeans.org/ns/project/1"); // NOI18N
        if
(!Util.findText(type).equals("org.netbeans.modules.apisupport.project")) { // NOI18N
            return null;
        }

Exception:

java.lang.NullPointerException
        at org.netbeans.modules.apisupport.project.Util.findText(Util.java:134)
        at
org.netbeans.modules.apisupport.project.universe.ModuleList.parseData(ModuleList.java:701)
        at
org.netbeans.modules.apisupport.project.universe.ModuleList.scanPossibleProject(ModuleList.java:289)
        at
tbeans.modules.apisupport.project.universe.ModuleList.findOrCreateModuleListFromSuiteWithoutBinaries(ModuleList.java:470)
        at
org.netbeans.modules.apisupport.project.universe.ModuleList.findOrCreateModuleListFromSuite(ModuleList.java:457)
        at
org.netbeans.modules.apisupport.project.universe.ModuleList$1.run(ModuleList.java:142)
        at org.openide.util.Mutex.readAccess(Mutex.java:269)
        at
org.netbeans.modules.apisupport.project.universe.ModuleList.getModuleList(ModuleList.java:121)
        at
org.netbeans.modules.apisupport.project.NbModuleProject.getModuleList(NbModuleProject.java:478)
        at
org.netbeans.modules.apisupport.project.queries.SubprojectProviderImpl.getSubprojects(SubprojectProviderImpl.java:65)
        at
org.netbeans.modules.project.ui.ProjectChooserAccessory.addSubprojects(ProjectChooserAccessory.java:398)
        at
org.netbeans.modules.project.ui.ProjectChooserAccessory$ModelUpdater.run(ProjectChooserAccessory.java:663)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:541)
        at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:963)
Comment 1 Jesse Glick 2007-02-20 19:52:17 UTC

*** This issue has been marked as a duplicate of 42686 ***