This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 97558

Summary: [Solaris]NPE on drawing links between a source tree node and a target tree node
Product: soa Reporter: Andrei Chistiakov <ca-nb>
Component: XSLTAssignee: Nikita Krjukov <supernikita>
Status: VERIFIED DUPLICATE    
Severity: blocker CC: astashkova, awegscheider, dmitry_markovski, ifilippova, kozlov, mmirilovic
Priority: P1 Keywords: RELNOTE
Version: 6.x   
Hardware: PC   
OS: Solaris   
Issue Type: DEFECT Exception Reporter:

Description Andrei Chistiakov 2007-03-09 12:08:48 UTC
Reproduced in build 070306_20 (JDK 1.6.0) on Solaris and Linux.

The issue is reproduced with jdk 1.6.0. If I use jdk 1.5.0_04, the scenario
works fine for me.

To reproduce the bug create an XSLT Service and link any node of the source tree
to a node of the target tree. The NPE throws.

java.lang.NullPointerException
        at sun.awt.X11.XSelection.checkChange(XSelection.java:749)
        at sun.awt.X11.XSelection.access$200(XSelection.java:30)
        at
sun.awt.X11.XSelection$SelectionEventHandler.dispatchEvent(XSelection.java:758)
        at sun.awt.X11.XToolkit.dispatchEvent(XToolkit.java:482)
        at sun.awt.X11.XToolkit.run(XToolkit.java:626)
        at sun.awt.X11.XToolkit.run(XToolkit.java:560)
[catch] at java.lang.Thread.run(Thread.java:619)
Comment 1 Nikita Krjukov 2007-03-13 11:22:37 UTC
The reason of the NPE is here: 

org.netbeans.modules.xslt.mapper.palette.XsltPaletteFactory

  public static class MapperPaletteTransferable extends ExTransferable.Single {

     protected Object getData() throws IOException, UnsupportedFlavorException {
            Node paletteItemNode = (Node)myPaletteItemLookup.lookup(Node.class);
            if (paletteItemNode != null) {
                DataObject dataObject = 
paletteItemNode.getCookie(DataObject.class);
                if (dataObject != null) {
                .....

The call to the method returns null
  paletteItemNode.getCookie(DataObject.class);
 
I've tried to figure out why it return null but it hasn't managed yet.
I'm going to communicate with the authors of the palette module. 
Comment 2 Nikita Krjukov 2007-03-13 11:25:08 UTC
My previous comment here was intended to another issue (Issue 97407)
Please don't take it into consideration. 
Comment 3 Nikita Krjukov 2007-03-20 12:28:35 UTC
We need an assistance from people who are responsible on the sun.awt.X11 
package. It looks like the defect in that Solaris specific code. 
Comment 4 Nikita Krjukov 2007-03-20 14:23:12 UTC
Oleg (Oleg.Sukhodolsky@Sun.COM) informed me that it is the AWT bug #6511815 
(bugster). 

He sad that it has been fixed in the java 7.0 

Special request has to be escalated to the AWT team if it necessary to fix it 
in the java 6.
Comment 5 Nikita Krjukov 2007-03-20 14:37:33 UTC
Here is the reference to the bugster bug:
   http://bt2ws.central.sun.com/CrPrint?id=6511815
Comment 6 Nikita Krjukov 2007-03-20 17:00:58 UTC
Here is the correct reference to the AWT bug
  http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6511815
Comment 7 Sergey Lunegov 2007-04-02 13:54:11 UTC
Candidate for RNs. Nikita, did you try to workaround this problem.
Comment 8 Nikita Krjukov 2007-04-10 14:07:38 UTC
I tried to workaround (together with Alexey Y.) but it didn't managed. 
I asked a person (Oleg Sukhodolsky) from awt team to look on it but he didn't 
suggest any workaround.
Comment 9 Sergey Lunegov 2007-04-10 16:06:32 UTC
User should use JDK 1.6 u2 on Solaris. It should be specified in RNs.
Comment 10 Sergey Lunegov 2007-04-16 15:46:05 UTC
The b02 (not FCS quality) is available on http://download.java.net/jdk6/binaries/.
It should contain fix for 6511815. Please verify bug has gone with this build of
JDK.
Comment 11 Andrei Chistiakov 2007-04-16 16:08:48 UTC
Looks like using b02 fixes the issue.
Comment 12 Sergey Lunegov 2007-04-16 16:21:13 UTC
Irina, please make sure this issue will be in RNs.
Comment 13 Irina Filippova 2007-04-16 16:56:11 UTC
Adding Alyona to CC because she is the RN responsible writer.
Comment 14 Sergey Lunegov 2007-04-18 08:13:21 UTC
Will be RN-ed.
Comment 15 Dmitry Markovski 2007-04-26 11:01:36 UTC
For the RN:

On Solaris and Linux, the XSL Transformation Editor throws an NPE when you 
create links between the Source tree and Destination tree nodes.
Workaround: use JDK 1.6 u2 available at http://download.java.net/jdk6/binaries/
Comment 16 astashkova 2007-04-26 13:53:44 UTC
Documented in NB 6.0 Preview RNs as follows:

Issue #97558: On Solaris and Linux, the XSL Transformation Editor throws an NPE
when you create links between the Source tree and Destination tree nodes.
Description: On Solaris and Linux, the XSL Transformation Editor throws an NPE
when you 
create links between the Source tree and Destination tree nodes.
Workaround: Use JDK 1.6 u02 available at http://download.java.net/jdk6/binaries/.
Comment 17 Marian Mirilovic 2007-04-28 20:35:15 UTC
r
Comment 18 Marian Mirilovic 2007-04-28 20:39:39 UTC
I would say RN should contains :
Issue #82142: On Solaris and Linux,
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6511815
every time you'll use Drag and Drop NPE rises.
Workaround: Use JDK 1.6 u02 available at http://download.java.net/jdk6/binaries/.

*** This issue has been marked as a duplicate of 82142 ***
Comment 19 Annette Wegscheider 2007-05-01 23:40:26 UTC
Since this issue is RESOLVED, it will not be included in the release notes.
In addition, http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6511815,
referenced in the next to last entry in this issue is also closed/fixed.
Comment 20 Annette Wegscheider 2007-05-02 19:27:34 UTC
Leaving in release notes per Sergey's request (reproducible on some supported
JDK versions). 
Comment 21 _ hong_lin 2007-08-15 20:09:00 UTC
Close "DUPLICATE" issue