This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 101697 - Move Refactoring of Java class uses import originalpackage.*;
Summary: Move Refactoring of Java class uses import originalpackage.*;
Status: RESOLVED DUPLICATE of bug 75076
Alias: None
Product: java
Classification: Unclassified
Component: Refactoring (show other bugs)
Version: 6.x
Hardware: All All
: P3 blocker (vote)
Assignee: issues@java
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-19 08:25 UTC by _ sandipchitale
Modified: 2007-08-14 12:36 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ sandipchitale 2007-04-19 08:25:35 UTC
When a class package1.Class1 is moved to package2 an:

import package1.*;

is inserted irrepective of 

- Class1 referes to or not referes to classes from package1
- import package1.*; is generally not a good this to use.

Please use resolve import like mechanism !?
Comment 1 Jan Becicka 2007-06-21 18:31:04 UTC
> Please use resolve import like mechanism !?
I'd like to. But there is no such thing, which would work in this case.
Comment 2 Jan Becicka 2007-06-27 14:37:47 UTC

*** This issue has been marked as a duplicate of 75076 ***