This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 103457 - New Project wizard hangs when connectivity is not working
Summary: New Project wizard hangs when connectivity is not working
Status: RESOLVED DUPLICATE of bug 191951
Alias: None
Product: projects
Classification: Unclassified
Component: Maven (show other bugs)
Version: 6.x
Hardware: All All
: P3 blocker (vote)
Assignee: Milos Kleint
Depends on:
Reported: 2007-05-07 21:33 UTC by Antonin Nebuzelsky
Modified: 2011-03-01 15:45 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Exception Reporter:

connectionFailed info message (3.94 KB, text/plain)
2007-05-07 21:42 UTC, Antonin Nebuzelsky

Note You need to log in before you can comment on or make changes to this bug.
Description Antonin Nebuzelsky 2007-05-07 21:33:02 UTC
I have a proxy setting set to internal firewall settings. However I tried
creating a new maven project when my notebook was connected to free internet.
The New Project wizard hanged with Processing Archetype step at 50%, at the
moment project-execute task was started. The log contains connectionFailed info

INFO [org.netbeans.core.NbProxySelector]: connectionFailed

I had to kill the NB instance.
Comment 1 Antonin Nebuzelsky 2007-05-07 21:42:38 UTC
Created attachment 42206 [details]
connectionFailed info message
Comment 2 Antonin Nebuzelsky 2007-05-07 21:47:58 UTC
When I tried next time, the wizard did not hang indefinitely. The exception
appeared in the log too, but the operation finished.

I think the difference between these two tries may be the quality of connection.
In both the cases I was not behind the firewall, but I suspect that in the first
case the connection dropped for some time and when it repaired the operation did
not continue anymore.

Anyway, the user should be warned that the connection is not available and the
user must be allowed to cancel the operation. Otherwise the user may need to
kill the IDE. That's too bad.
Comment 3 Milos Kleint 2007-05-09 08:24:17 UTC
when the connection is not available (like when I plug out the ethernet cable)
the  connection shall fail fast. (BTW what OS are you running on?)

There is no way to cancel the project wizard when instantiating, because the
wizard infrastructure disables all the buttons.

I'm not aware of a bulletproof way of "testing" the connection without actually
hanging the wizard anyway. Also please note that once you've sucessfully ran the
wizard once you most probably won't need the network to create the next project.
(as I do frequently when off-network)

we could probably present the "proxy" button to the user at the last panel that
would lead to ide's proxy settings along with explanatory text.


Comment 4 Milos Kleint 2007-10-05 13:02:22 UTC
things get a bit more complicated with the introduction of command-line maven instance for building.

the embedded version uses IDE's proxy settings first and then maven own's settings in ~/.m2/settings.xml. Values are
additive here. Unfortunately we don't seem to be able to disable the IDE's proxy settings while running in the same VM.

command line maven uses only settings in ~/.m2/settings.xml (and global ones in MAVEN_HOME/conf/settings.xml) and is not
influenced by IDE's settings.

if the user has the m2 settings setup correctly we should be fine, problems only arise when IDE's settings differ from
the maven's settings I suppose.

Comment 5 Milos Kleint 2008-09-17 08:12:13 UTC
I've experienced a similar situation on loading project that had defined as repository.
Unfortunately the server doesn't fail fast but takes time to timeout. With repeated requests to the server, project
loading, library downloads or build executions seem to hang but they *will* eventually finish (after a pretty long time
depending on how frequently the wrong repository gets touched.

I don't think we can do anything about it on the IDE integration side unfortunately. Closing as wontfix. Might be
something t file against maven itself, but still I don't see what the fix would involve.
Comment 6 Jesse Glick 2011-03-01 15:45:18 UTC
More detailed API discussion in other issue even though newer.

*** This bug has been marked as a duplicate of bug 191951 ***