This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 109565 - ForEach property 'completion condition' should be renamed to 'branches'
Summary: ForEach property 'completion condition' should be renamed to 'branches'
Status: NEW
Alias: None
Product: soa
Classification: Unclassified
Component: BPEL (show other bugs)
Version: 6.x
Hardware: All All
: P4 blocker (vote)
Assignee: Sergey Lunegov
Depends on:
Reported: 2007-07-12 21:05 UTC by vinayram
Modified: 2007-12-07 16:35 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:

Capture of the forEach properties window. (31.56 KB, application/octet-stream)
2007-07-12 21:05 UTC, vinayram

Note You need to log in before you can comment on or make changes to this bug.
Description vinayram 2007-07-12 21:05:30 UTC
The property 'completion condition' for the ForEach construct should be called 'branches' since that is the element 
under which the value goes to.

1. Create a bpel with a ForEach structured activity.
2. Right click and select properties.
3. The ForEach properties dialog has a property called 'Completion Condition'. This SHOULD BE 'Branches'.
4. set a property say '5' for that property.
5. Switch to the source view and view the generated code.
   The generated code should look similar to:

<forEach name="ForEach1" parallel="no" counterName="counter">
         <scope name="Scope2">

Completion condition has an element called branches to which the value of '5' is assigned to. To truly reflect what 
the value means the property should be called 'Branches'.
Comment 1 vinayram 2007-07-12 21:05:49 UTC
Created attachment 45046 [details]
Capture of the forEach properties window.