This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 118886 - [60cat] UML element name editing keeps focus until enter is pressed
Summary: [60cat] UML element name editing keeps focus until enter is pressed
Status: VERIFIED FIXED
Alias: None
Product: uml
Classification: Unclassified
Component: General (show other bugs)
Version: 6.x
Hardware: PC Windows XP
: P2 blocker with 1 vote (vote)
Assignee: Thuy.d Nguyen
URL:
Keywords: REGRESSION
: 118991 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-10-15 13:45 UTC by _ wadechandler
Modified: 2007-10-23 22:03 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ wadechandler 2007-10-15 13:45:17 UTC
[ JDK VERSION : 1.6.0_01 ]

While on a UML element and entering the name, comment, etc [such as
in use case diagrams] the UML editor keeps focus even when clicking
off the component. This makes it harder to use as generally folks
will grab the mouse and attempt to move on to the next element
without having to actually press enter. Clicking off an edited
element in this case should keep the currently entered value and just
as pressing enter. 

One can not even choose to save the current model or access other
menues. If this kept the data when clicked off even the menus could
become usable in this state. The first time it happened that I could
not click on a menu I thought at first the IDE had locked. I've set
as a P1 as it severely affects usability if I already have my hand on
my mouse and need to move on to the next element or if I don't know
it will do such a thing and I might think the IDE is locked up.
Comment 1 Peter Lam 2007-10-15 17:48:17 UTC
Thanks for filing the issue. Actually this is a regression from NB 5.5/5.5.1.
I downgraded it to a P3 per the following bug guideline.

does not work:	Part of a product feature is affected, a viable workaround exists
usability:	Highly visible usability problem

Workaround:  pressing the Enter key first.
Comment 2 George Vasick 2007-10-15 17:49:52 UTC
Upgrading to P2 since it is highly visible.
Comment 3 Thuy.d Nguyen 2007-10-15 22:16:49 UTC
I've made the edit control dialog modal recently which causing this issue.  I just changed the model back to modeless
and checked in to trunk.
Comment 4 Thuy.d Nguyen 2007-10-16 21:09:04 UTC
*** Issue 118991 has been marked as a duplicate of this issue. ***
Comment 5 Peter Lam 2007-10-23 22:03:09 UTC
verified trunk build 20071023-b4116.