This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 123017 - Netbeans 6.0 rc2 - no RESTful web-services project-folder generated on OS X 10.5.1
Summary: Netbeans 6.0 rc2 - no RESTful web-services project-folder generated on OS X 1...
Status: VERIFIED DUPLICATE of bug 123006
Alias: None
Product: webservices
Classification: Unclassified
Component: REST (show other bugs)
Version: 6.x
Hardware: Macintosh All
: P2 blocker (vote)
Assignee: Nam Nguyen
Depends on:
Reported: 2007-11-28 21:59 UTC by Ayub Khan
Modified: 2008-01-21 01:16 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:

javafx plugin (109.51 KB, text/plain)
2007-11-29 18:45 UTC, Ayub Khan
catalog from where the javafx was downloaded (90.62 KB, image/png)
2007-11-29 18:46 UTC, Ayub Khan
javafx plugin snapshot again (png mimetype, ignore other one) (109.51 KB, image/png)
2007-11-29 18:48 UTC, Ayub Khan

Note You need to log in before you can comment on or make changes to this bug.
Description Ayub Khan 2007-11-28 21:59:08 UTC
Issue Reported by external user.

I've followed the tutorial several times and at " Generating RESTful Web Services from
Entity Classes" step 3 and 4 I don't see the RESTful web-services project folder created.

I see source files created under 'Source Packages'. My version of the project doesn't run
or test-run.
Comment 1 Ayub Khan 2007-11-28 22:04:51 UTC
Follow this tutorial for reproducing the issue


Can you please take a look at the NPE reported by user. This is reported on Mac OSX 10.5.1, and I could not reproduce
it, on the same environment.

       at org.openide.loaders.DataObject.createFromTemplate(

From Nam,

Just by looking at the stack trace code,  I filed issue against java/source module:

I suspect user IDE has some additional plugins that you don't have.  Please check with him to see if this is the case. 
Comment 2 robertmacgregor 2007-11-29 03:07:01 UTC
On 28-Nov-07, at 5:26 PM, Nam Tuan Nguyen wrote:


>I assume you experienced the problem using the binaries from
>with Web&JavaEE selection?

I downloaded binaries from the all-features section for a Mac OS X OS.

>Do you by any chances install additional plugins aside from the 'RESTful Web Services' plugin?  If so, could you try
>uninstall those addtional plugins and see if the problem still happen? <>

I uninstalled the plugins one-by-one and retested. The issue was resolved (and RESTful services generated) after I
removed the 'JavaFX Weather Sample':

JavaFX Weather Sample

Version: 1.0
Date: 11/26/07
Source: NetBeans Beta

Plugin Description

Sample Application shows 2 days Weather forecast for 3 different cities using information from a real weather service.   
Comment 3 Nam Nguyen 2007-11-29 05:55:46 UTC
Thanks so much for you contribution, Robert.

I guess this is specific for Mac OS, since I tried installing JRuby, JavaFX and Weather Samples plugins but still 
create RESTful web services from entities fine.  I am on Windows.  Ayub, could you please confirm this test case with 
your Mac laptop.
Comment 4 Ayub Khan 2007-11-29 18:45:00 UTC
I tried installing JavaFX Script, Weather sample plugin on top of NB 6.0 RC2 (NB All bits from 11/19), and I couldn't
reproduce it on my Mac OSX 10.5.1. See attachments javafx, catalog.
Comment 5 Ayub Khan 2007-11-29 18:45:48 UTC
Created attachment 53682 [details]
javafx plugin
Comment 6 Ayub Khan 2007-11-29 18:46:34 UTC
Created attachment 53683 [details]
catalog from where the javafx was downloaded
Comment 7 Ayub Khan 2007-11-29 18:48:17 UTC
Created attachment 53684 [details]
javafx plugin snapshot again (png mimetype, ignore other one)
Comment 8 Nam Nguyen 2008-01-14 22:54:10 UTC
The relationship with issue 123006 is actually duplication.

*** This issue has been marked as a duplicate of 123006 ***
Comment 9 Lukas Jungmann 2008-01-21 01:16:19 UTC
v. dup.