This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 125371 - Context actions clean up
Summary: Context actions clean up
Status: RESOLVED DUPLICATE of bug 129087
Alias: None
Product: versioncontrol
Classification: Unclassified
Component: Mercurial (show other bugs)
Version: 6.x
Hardware: All All
: P3 blocker (vote)
Assignee: issues@versioncontrol
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-01-16 12:25 UTC by Peter Pis
Modified: 2008-03-05 19:44 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Pis 2008-01-16 12:25:14 UTC
IMHO, some actions like 
* Clone
* Push to
* Pull from
* Properties

Shouldn't be available in context menu because they are not context sensitive and therefore it would be better to have
only in Mercurial main menu.
Comment 1 John Rice 2008-01-16 15:21:53 UTC
Peter - they are context sensitive. I find myself using them from the context menu quite a bit and its much clearer to
me what exactly is the context I'm working with at that time, so I know exactly what I'm Cloning, Pulling/ Pushing from
or checking Properties of.

So in the ctx menu:
Clone is context dependent - it is cloning the project you are right clicking on.
Push to default - if available is pushing to this projects clone parent.
Pull from default - if available is pulling from this projects clone parent.
Properties - is bringing up the properties for the project you are right clicking on.
Comment 2 Peter Pis 2008-01-16 19:33:18 UTC
What I mean is: whatever you select (package, file) from e.g. "Projects" window the result is the same for "Push",
"Pull", .... Entire project is processed. Let's suppose commit action. If it's invoked, only files that belong to the
selected directory are processed (if other directory contains modified files then they are not processed), not the
entire project. And that's the difference for me. But it's just my opinion. ;-)
Comment 3 John Rice 2008-01-16 19:45:36 UTC
Ah OK - I understand exactly what you mean, but I do find it very handy to have these commands available to me on the
ctx menu when I'm working with the repos. 

So for now I'd vote to leave as is, but if we get strong opinions to the contrary we can always change them of course.

Comment 4 John Rice 2008-02-06 11:27:02 UTC
Will leave for now awaiting user feedback.
Comment 5 Peter Pis 2008-02-12 09:17:49 UTC
So I would reopen it and keep it open as ENHANCEMENT.
Comment 6 John Rice 2008-03-05 19:44:10 UTC

*** This issue has been marked as a duplicate of 129087 ***