This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 129261 - Wrong or missing Navigator tree
Summary: Wrong or missing Navigator tree
Status: RESOLVED FIXED
Alias: None
Product: platform
Classification: Unclassified
Component: Navigator (show other bugs)
Version: 6.x
Hardware: All All
: P3 blocker (vote)
Assignee: Jan Peska
URL:
Keywords:
: 130826 201333 (view as bug list)
Depends on:
Blocks: 131125
  Show dependency tree
 
Reported: 2008-03-05 10:56 UTC by Martin Schovanek
Modified: 2011-10-26 14:23 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments
Empty Navigator (40.29 KB, image/png)
2008-03-05 10:57 UTC, Martin Schovanek
Details
A screenshot from automated test. (54.74 KB, text/plain)
2008-03-05 11:04 UTC, Martin Schovanek
Details
A screenshot from automated test (with correct mimetype). (54.74 KB, image/png)
2008-03-05 11:07 UTC, Martin Schovanek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Schovanek 2008-03-05 10:56:45 UTC
[#200803050006, jdk1.5.0]

to reproduce:
-------------
1) move the Navigator view at on the same window area as Projects view (the views overlaps)
2) open a Visual JSP page
3) choose the Visual Editor JSP view
4) choose the Projects view (the Navigator is hidden behind it)
5) choose the Visual Editor Design view
6) choose the Navigator view

ERROR: the Navigator view is empty or displays JSP tree.

Next, have similar problem during automated tests execution where the Navigator is in his standard position.
Comment 1 Martin Schovanek 2008-03-05 10:57:41 UTC
Created attachment 57794 [details]
Empty Navigator
Comment 2 Martin Schovanek 2008-03-05 11:04:21 UTC
Created attachment 57796 [details]
A screenshot from automated test.
Comment 3 Martin Schovanek 2008-03-05 11:07:25 UTC
Created attachment 57797 [details]
A screenshot from automated test (with correct mimetype).
Comment 4 Martin Schovanek 2008-03-05 11:10:48 UTC
The automated test failed at:
org.netbeans.modules.visualweb.test.components.action.tree.AcceptanceTest.testConfigureTreeNodes(AcceptanceTest.java:309)
Comment 5 Peter Zavadsky 2008-03-05 17:10:00 UTC
There are already similar issues, when the navigator doesn't set the correct impl in it. The content is in control of
the navigator core impl. Passing there.
Comment 6 David Simonek 2008-03-05 17:27:02 UTC
Hardly P2, this is corner case IMHO...
Comment 7 David Simonek 2008-03-14 15:39:07 UTC
*** Issue 129896 has been marked as a duplicate of this issue. ***
Comment 8 _ krystyna 2008-03-14 18:54:15 UTC
Re-instating P2 because as the external reporter of closed duplicate issue #129896 said, once the view is 
lost in Navigator for the JSP view, they need to restart to regain it.

Here are reproducible directions from NetBeans IDE Dev (Build 200803141205):
1. create a VW project - don't drop any components
2. tab click on JSP view
3. tab click on Java view (let all members get populated)
4. tab click on JSP view
>Navigator view is empty for the JSP view

5. return to design view and drag and drop one or two components, tab switch to JSP view
>Navigator view is still empty for the JSP view

6. Close and restart IDE to see the JSP view


Original reporter's scenario is likely different, but this is best way
for me to reproduce. I have seen the Navigator view go blank for JSP 
view before.

Comment 9 David Simonek 2008-03-17 18:34:28 UTC
Krystyna, I reproduced the problem - but it's another bug, bug somewhere inside JSP navigator view itself - please take
your reproducible steps and file new issue against JSP navigator view -you can see on your screen during reproduction
steps that navigator is *not* empty - it contains JSP navigator view correctly, but JSP view somehow fails to display
structure. Thank you.

On the other side, original problem is different and is really on the side of core/navigator, where different provider
is set somehow.

My steps for reproduction (with original I failed):
1, 2 the same 
3) click into projects view
4) click into Visual editor (still on Design tab)
5) click into projects view again
6) click the tab to show navigator -> it will incorrectly show JSP view navigator instead of Design view navigator.

making it P3 again as P2 is different bug, probably in JSP nav view itself, as I explained above.
Comment 10 _ krystyna 2008-03-17 20:05:52 UTC
okay, I'll just then revert #129896 which you closed as a duplicate of this.
Comment 11 David Simonek 2008-03-26 09:11:13 UTC
*** Issue 130826 has been marked as a duplicate of this issue. ***
Comment 12 Lukas Hasik 2008-04-10 21:22:33 UTC
moving opened issues from TM <= 6.1 to TM=Dev
Comment 13 Jan Peska 2011-10-24 12:01:44 UTC
*** Bug 201333 has been marked as a duplicate of this bug. ***
Comment 14 Jan Peska 2011-10-25 06:41:30 UTC
fix: http://hg.netbeans.org/core-main/rev/0efb7e9ae613
Comment 15 Quality Engineering 2011-10-26 14:23:30 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/0efb7e9ae613
User: Jan Peska <jpeska@netbeans.org>
Log: Issue #129261 - Wrong or missing Navigator tree
Empty navigator panel fixed