This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 130826 - Navigator display empty
Summary: Navigator display empty
Status: RESOLVED DUPLICATE of bug 129261
Alias: None
Product: platform
Classification: Unclassified
Component: Navigator (show other bugs)
Version: 6.x
Hardware: PC Windows XP
: P3 blocker (vote)
Assignee: David Simonek
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-21 20:56 UTC by abhidesh
Modified: 2008-12-22 13:49 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments
The IDE log (126.61 KB, text/plain)
2008-03-21 20:58 UTC, abhidesh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description abhidesh 2008-03-21 20:56:19 UTC
The Navigator window displays <No View Available> when a visual web JSF page is selected.

When the IDE first comes up, it does display the page components correctly. After it's been up for some, it starts 
displaying <No View Available> in the navigator window.

Environment details
===================
Product Version: NetBeans IDE 6.0.1 (Build 200801291616)
Java: 1.6.0_04; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)
Userdir: C:\Documents and Settings\adeshpande\.netbeans\6.0

IDE log attached.
Comment 1 abhidesh 2008-03-21 20:58:02 UTC
Created attachment 58869 [details]
The IDE log
Comment 2 _ potingwu 2008-03-25 18:14:31 UTC
I see lots of exceptions from insync, please evaluate.
Comment 3 John Baker 2008-03-25 18:28:46 UTC
In the attached log file, there are lots of exceptions from dataconnectivity.  I recently evaluated and found the cause
of the exceptions and made some fixes so the NPEs don't occur.  The cause is a mismatch in the data source
initialization generated code in SessionBean1 with the data source defined in the server configuration file.  User
either changed or removed the data source setting in SessionBean1 (assuming the rowset is in SessionBean1) or
edited/removed the server configuration file.  

However, the exceptions in dataconnectivity do not prevent the Navigation window from opening. I think there is another
issue tracking this
Comment 4 Peter Zavadsky 2008-03-26 01:05:12 UTC
So I assume that the NPE's were fixed. The problem with navigator, there are more issues describing it. Passing to the
correct component.
Comment 5 David Simonek 2008-03-26 09:11:13 UTC
Most likely duplicate of 129261.

*** This issue has been marked as a duplicate of 129261 ***