This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 131030 - Navigation in js code doesn't work in j2seproject
Summary: Navigation in js code doesn't work in j2seproject
Status: NEW
Alias: None
Product: javascript
Classification: Unclassified
Component: Editor (show other bugs)
Version: 6.x
Hardware: All All
: P4 blocker (vote)
Assignee: Petr Pisl
: 131831 (view as bug list)
Depends on:
Reported: 2008-03-25 13:55 UTC by Milan Kubec
Modified: 2014-01-16 10:28 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Note You need to log in before you can comment on or make changes to this bug.
Description Milan Kubec 2008-03-25 13:55:15 UTC
Product Version: NetBeans IDE Dev (Build 200803050006)
Java: 1.6.0_05; Java HotSpot(TM) Client VM 10.0-b19
System: Linux version 2.6.22-14-generic running on i386; UTF-8; en_US (nb)

Navigation in javascript file in editor doesn't work. Either 'Ctrl+Click' or 'Ctrl+B' just beeps and does nothing.
Comment 1 Torbjorn Norbye 2008-03-26 05:14:42 UTC
More details please... what exact symbol are you clicking on, and where is it defined? Is it a function or a variable?
Can you attach your source?
Comment 2 Milan Kubec 2008-03-26 08:06:26 UTC
I was editing file and I was clicking on usage of any function or variable defined
inside deployJava.
Comment 3 Torbjorn Norbye 2008-04-01 23:40:49 UTC
I can not reproduce this. 

I copied deployJava.js into my Rails project (a Web Project would also work).  I then tried clicking on function calls,


(I clicked on compareVersionToPattern - and it jumped to the right place.  I clicked on the global var reference
(deployJava) and it worked.

I also clicked on the "jnlp" local variable in the launch method and it correctly jumped to the parameter list.  

Can you list more specifically what you did -- how did you edit deployJava.js (project type etc) - you cannot edit http
resources directly.  Which specific symbols did you click on?   Also, can you try a more recent build? (If I read this
correctly, you have a build that is nearly a month old). Perhaps try with a cleanuser dir also in case there is stale
indexing data in there.
Comment 4 Martin Schovanek 2008-04-02 13:30:22 UTC
It does not work at Java Project, at Web project works well.
Comment 5 Milan Kubec 2008-04-02 14:28:26 UTC
Yes, I can verify that navigation in JavaScript file inside web project works OK. I used j2seproject.
Comment 6 Torbjorn Norbye 2008-04-02 16:08:24 UTC
Features based on the index, such as code completion and go to declaration, only work in projects enabled for JavaScript
(such as Ruby on Rails and Web Project (e.g. see issue 131831).
Comment 7 Milan Kubec 2008-04-02 20:21:29 UTC
OK, then we can close the issue? Or do you plan to enable it also for other project types?
Comment 8 Petr Jiricka 2008-04-03 10:24:38 UTC
I suggest leaving it open and treating it as a P4 defect. Milan agrees (as the submitter).
Comment 9 Milan Kubec 2008-04-03 10:38:50 UTC
Changing the summary.
Comment 10 Torbjorn Norbye 2008-04-04 23:19:03 UTC
*** Issue 131831 has been marked as a duplicate of this issue. ***