This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 133581 - java.lang.IllegalArgumentException: URI scheme is not "file"
Summary: java.lang.IllegalArgumentException: URI scheme is not "file"
Status: NEW
Alias: None
Product: obsolete
Classification: Unclassified
Component: visualweb (show other bugs)
Version: 6.x
Hardware: All All
: P3 blocker with 1 vote (vote)
Assignee: Winston Prakash
Depends on:
Reported: 2008-04-22 06:27 UTC by schinni
Modified: 2009-05-25 21:07 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter:

The Exception and the data that netbeans tried to send (294.35 KB, text/plain)
2008-04-22 06:34 UTC, schinni
The project Properties file (9.40 KB, text/plain)
2008-04-23 02:47 UTC, schinni

Note You need to log in before you can comment on or make changes to this bug.
Description schinni 2008-04-22 06:27:33 UTC
When I tried to open an existing Visual Web JSF project (created in Netbeans 6.0), the system threw an error :
java.lang.IllegalArgumentException: URI scheme is not "file". Thus, I am unable to work on my project using Netbeans 6.1

Also, whenever I am trying to do the auto review and report. It fails. The 'Uploading log file' goes all the way to 95%
and then i get an error message saying "Upload of log to failed, please report the problem at ..."
Comment 1 schinni 2008-04-22 06:34:34 UTC
Created attachment 60526 [details]
The Exception and the data that netbeans tried to send
Comment 2 _ potingwu 2008-04-22 17:06:21 UTC
Could you please attach your project to this issue? I cannot reproduce it without your project. Thanks!
Comment 3 _ potingwu 2008-04-22 18:50:31 UTC
If your project is big or intellectual, please just attach your project's property file:


Comment 4 schinni 2008-04-23 02:47:21 UTC
Created attachment 60583 [details]
The project Properties file
Comment 5 _ potingwu 2008-04-23 17:58:39 UTC
Could you please try to remove all values under the following comments in your file:
    # Property libs.Commons.classpath is set here just to make sharing of project simpler.
    # The library definition has always preference over this property.

Sometime these 'cache' do not work properly because they are not updated correctly.

Do make a copy before removing them. If it's still not working, then restore it.
Comment 6 schinni 2008-04-24 02:13:01 UTC
I did as asked (modifying the file). However, the problem still remains. 
Comment 7 _ potingwu 2008-04-24 03:08:58 UTC
From the threads dump, looks like a general web project, or IDE project issue. Assign to web project for further
Comment 8 David Konecny 2008-04-24 03:47:41 UTC
I do not know how you ended up with your project in this state but looking at there seems to be jars
referenced from two NetBeans installations:
* E:\\Program Files\\NetBeans 6.1 RC2
* C:\\Program Files\\NetBeans 6.0.1

Could you open Tools->Libraries and scroll through all libraries you have there and check whether some of them is
broken? Should be displayed in red. Fixing that should resolve also your project opening issue.

If you know how to reproduce this problem would be great. I think it depends on the IDE libraries your project is using
in NB 6.0. And it looks to me like one of them is not provided in NB 6.1? Is that possible? Thanks, -David
Comment 9 schinni 2008-04-24 04:02:16 UTC
I even tried creating a new project from scratch (using the existing sources option). However, when i was adding
libraries to my project, i got this error again. Also, i was unable to open any jsp page for editing. At this point, i
thought restarting netbeans might help. Upon restarting, netbeans gave me the same error again (URI scheme is not
"file") and this time i saw it automatically remove the project i had created earlier from the projects pane. 

I tried this process three times - each time with the same result. Hence, we cannot develop at all using Netbeans 6.1
RC2. Please help... 
Comment 10 schinni 2008-04-24 04:13:48 UTC
Response to david...

All the libraries are ok. None is red. 

I am able to reproduce the problem on my pc. I will try and reproduce it on other pcs too. All the libraries that my
project is using, are available. When I had created a new project and added all the libraries, there were no errors
prompted. I was even able to compile the project successfully. However, I was unable to open any jsp page. It sort of
hung. And as mentioned in my previous post, upon restarting the IDE, the IDE threw the URI scheme is not "file" error
and removed the project from the Projects pane. Trying to add it back again results in the same problem. 
Comment 11 David Konecny 2008-04-24 04:31:54 UTC
From the exception I can see where the problem is but I would like to figure out how to reproduce it.

Two things I would like to ask you to try please:

* I was not correct in my previous reply that broken library would be displayed in red. It is the jar of a library which
 is displayed in red if it cannot be translated to physical jar file on disk. Could you please go to Tools->Libraries
again and select each library your project is using (or go through all of them if unsure) and when library is selected
check that classpath list contains valid items - broken one should be displayed in red. If there is one fix it by
removing broken library entry and adding correct one.

* you said "I even tried creating a new project from scratch (using the existing sources option)" - this definitely
should work. If first step does not help could you please try to start NB6.1RC2 with fresh userdir (e.g. netbeans
--userdir /tmp/tmp-nb-userdir) and recreate the project again? Pay attention especially to all libraries you are going
to use.
Comment 12 schinni 2008-04-25 17:53:24 UTC
The first step worked. I found that the Web UI components library was referencing dojo and scriptaculous which were
missing. Upon removing them, i was able to load my project successfully. Thanks =). 

A point to note: It seems like we cannot have multiple versions of netbeans installed on the same system. I had version
6.0.1 on my system when i installed 6.1 RC2. Even uninstalling both and reinstalling only 6.1 RC2 hadn't helped reset
this library. The manual update worked like a charm though. 
Comment 13 _ potingwu 2008-04-25 18:08:21 UTC
> The first step worked. I found that the Web UI components library was referencing dojo and scriptaculous which were
> missing. Upon removing them, i was able to load my project successfully. Thanks =).

I think Visual Web component may need to release note this issue, or describe the problem in details to see how the IDE
general project can automatically resolve this.

Visual Web QA may want to check whether this issue will always happen when multiple NetBeans versions coexist.
Comment 14 David Konecny 2008-04-28 00:05:26 UTC
Re. "It seems like we cannot have multiple versions of netbeans installed on the same system" - it should work without
problems. I still do not know how to reproduce your problem and without that it is difficult to fix it. Here is what I

Note: NB6.0.1 when installed and run on fresh computer will create IDE userdir directory <user-home>/.netbeans/6.0 . NB
6.1rc2 when started for the first time will check presence of "<user-home>/.netbeans/6.0" and will offer "import 6.0
settings?" and will create IDE userdir directory <user-home>/.netbeans/6.1rc2 .

To try to reproduce the problem I did:
* I removed <user-home>/.netbeans/6.0 and started NB6.0.1 and created Web Project with Visual JSF (that it project with
Web UI Components library) and exited IDE
* I removed <user-home>/.netbeans/6.1rc2 and started NB6.1rc2 and said "Yes" to import 6.0 settings
Result of this was that project created in 6.0 was successfully opened in 6.1rc2 and I can see it's using "Web UI
Components" library and that library was upgraded to 6.1rc2 version. So for me everything seems to be working fine.

Btw. what you mean by "scriptaculous" - I'm not expert in Visual JSF but in 6.0 I did not have any scriptaculous.jar on
Comment 15 schinni 2008-04-28 03:07:52 UTC
The scriptaculous 1.5.0 jar was i think in the following location: NetBeans default installation

With regards to the installation, I originally had netbeans 5.5 on my system. I had then uninstalled it and installed
netbeans 6 last december. Upon the release of 6.0.1, i had installed 6.0.1 (i do not remember if i had uninstalled 6.0
or the 6.0.1 installation used the same folder). A week back, I had installed 6.1 RC2 and the problem i described
earlier came about. 
Comment 16 David Konecny 2008-04-29 00:29:33 UTC
Passing back to visualweb team. You guys know about changes of Web UI Components library so it should be easier for you
to figure out scenario how to reproduce the problem. Knowing which users are really impacted (NB6 users? or NB5.5
users?) you can decide whether it is worth to mention this problem in Release Notes or not or do something else.
Comment 17 _ potingwu 2008-04-29 00:54:59 UTC
The Web UI Components team should know better how the libraries have been changed and may need to release note about it.