This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 139021 - Guarded blocks get messed if .java with error is saved
Summary: Guarded blocks get messed if .java with error is saved
Status: RESOLVED DUPLICATE of bug 138692
Alias: None
Product: guibuilder
Classification: Unclassified
Component: Code (show other bugs)
Version: 6.x
Hardware: All All
: P3 blocker with 1 vote (vote)
Assignee: issues@guibuilder
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-04 11:38 UTC by carentrica
Modified: 2008-07-08 13:34 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments
screen shot of source file in the editor (87.87 KB, image/jpeg)
2008-07-04 11:39 UTC, carentrica
Details
Java source file containg the corruptions (30.83 KB, text/plain)
2008-07-04 11:42 UTC, carentrica
Details

Note You need to log in before you can comment on or make changes to this bug.
Description carentrica 2008-07-04 11:38:49 UTC
I have a very big problem with one of my projects that got saved with a single error still in the code.

In many of the guarded blocks of code, the gray area was covering half of the java statements I had previously entered
so that I couldn't edit those areas. I had to open the file in another editor and manually fix it. It was quite a large
file and took nearly 40 minutes.

When I had finally fixed it, I made a copy of the project, edit one of the .java files to deliberately create an error
in the code, saved it, closed it, and re-opened it.

The attached screen shows the problem.

I'm using a very recent dev build:
Product Version: NetBeans IDE Dev (Build 20080703012507)
Java: 1.6.0_05; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; Cp1252; en_GB (nb)
Comment 1 carentrica 2008-07-04 11:39:55 UTC
Created attachment 63937 [details]
screen shot of source file in the editor
Comment 2 carentrica 2008-07-04 11:42:38 UTC
Created attachment 63938 [details]
Java source file containg the corruptions
Comment 3 Vadiraj Deshpande 2008-07-04 12:11:59 UTC
I too have seen this on Windows XP using latest (07/02) build.
Comment 4 Jiri Vagner 2008-07-08 13:34:28 UTC
Thank you for your issue report.

*** This issue has been marked as a duplicate of 138692 ***