This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 143615 - CVS Invalid project pop-up menu after import
Summary: CVS Invalid project pop-up menu after import
Alias: None
Product: versioncontrol
Classification: Unclassified
Component: CVS (show other bugs)
Version: 6.x
Hardware: All All
: P3 blocker (vote)
Assignee: issues@versioncontrol
Depends on:
Reported: 2008-08-12 15:03 UTC by pribyl
Modified: 2010-07-30 09:55 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:

Project root menu (26.14 KB, image/gif)
2008-08-12 15:05 UTC, pribyl
Msg log (29.48 KB, text/plain)
2008-09-01 16:47 UTC, pribyl

Note You need to log in before you can comment on or make changes to this bug.
Description pribyl 2008-08-12 15:03:55 UTC
Product Version: NetBeans IDE 6.5 Beta (Build 200808111757)
Java: 1.6.0_10-rc; Java HotSpot(TM) Client VM 11.0-b15
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)

I created new Project (simple J2SE) and imported it into CVS repository. When I right-clicked on the project root node,
the only option under CVS was "Import into CVS Repository" - I could not for example Show changes, or Commit (neither
using the right-click menu, nor Versioning menu)

I could however invoke those options normally on a single file or package. The only problem was the project root.
Comment 1 pribyl 2008-08-12 15:05:01 UTC
Created attachment 67145 [details]
Project root menu
Comment 2 Maros Sandor 2008-08-20 11:40:43 UTC
Try to select some other node, open the CVS menu and then select the Project node again and open the CVS menu. Did it
help or do you still see only the Import action?
Comment 3 pribyl 2008-08-21 12:35:52 UTC
It is still the same.

Well, but I just observed, that this is only a problem of projects created into C:\Documents and Settings\pavel\My
Documents\NetBeansProjects , my default projects directory. I have other projects there, some of them are also under CVS
version control. Maybe this causes the trouble?

I tried to create a project in a different directory, and the problem was gone. To be more specific, I tried:

1, C:\Documents and Settings\pavel\My Documents\NBPs\ - and it worked fine 
2, C:\Documents and Settings\pavel\My Documents\NetBeansProjects\NBPs\ - and the problem was there again
Comment 4 Maros Sandor 2008-08-21 12:38:07 UTC
Does IDE restart help? Or did you find some other way to make it work?
Comment 5 pribyl 2008-08-21 12:57:54 UTC
Restarting did not help. I tried to delete my usedir, and still the same result.

However, as I wrote earlier, it is a problem of the default directory in My Documents. I tried to delete it and let
NetBeans to create new one and place new project there - and the problem was there again.

After this experience i am not sure, whether it is still a NB problem, or whether my default directory is cursed :)
Comment 6 Maros Sandor 2008-08-21 12:59:13 UTC
Let's assume it is cursed and close this issue ;-)
Comment 7 pribyl 2008-08-21 13:32:10 UTC
:)  It is OK with me. On the other hand, there may be a (very little) chance, that this may be caused by NetBeans.
I just tried to uninstall NB 6.5 beta and installed 6.1 - everything was working just fine, even in the cursed directory.

I uninstalled 6.1., deleted cursed directory, deleted userdir, installed beta again - the curse is back.

Then I tried ultimate exorcism - In 6.5 beta I created new project and imported it into CVS repo (the problem was there
again). I closed 6.5 and run 6.1, opened the same project - and surprisingly everything worked perfectly.
Comment 8 Petr Dvorak 2008-09-01 13:20:50 UTC
I think this one is easy to reproduce, start IDE with a clean userdir, create some project (JavaApplication1) and then
checkout a project of the same name (JavaApplication1)... Only one project is in Projects view, wrong popup menu is

Is this right, Pavel?
Comment 9 pribyl 2008-09-01 16:45:06 UTC
Well, that may be a way to reproduce, yes. But right now I am really stuck with CVS and I cannot even try to reproduce that.

On latest build (Dev 200809010201) I can create a poject with unique name, in any folder, import it into CVS repository
(succesfully), but after that it does not act like CVS versioned project. On the content menu, I got again the
"Versioning >" option with (3 default sub-options) and when I try to Import it again into CVS repo, it states it is
already versioned.


I just noticed in messages.log, that I obtained this warning:
#65188 warning C/S protocol error (section 5.10). It's regurarly observed with cvs 1.12.xx servers.
  unexpected pathname=JavaApplicationABCPribyl/ missing root prefix=/usr/cvsrepo
  relaxing, but who knows all consequences....

(I am attaching the whole messages.log)

I am using Peter's repository at , and it always worked for me quite
fine. May the problem be in there?
Comment 10 pribyl 2008-09-01 16:47:27 UTC
Created attachment 68806 [details]
Msg log
Comment 11 Maros Sandor 2008-09-03 12:37:04 UTC
I tried to flush the cache after import so this should not happen anymore.
Comment 12 Quality Engineering 2008-09-03 17:33:48 UTC
Integrated into 'main-golden', will be available in build *200809031401* on (upload may still be in progress)
User: Maros Sandor <>
Log: #143615: CVS did not correctly flush its unversioned ancestors cache
Comment 13 pribyl 2008-10-13 08:33:56 UTC
Product Version: NetBeans IDE Dev (Build 200810111401)
Java: 1.6.0_10-rc; Java HotSpot(TM) Client VM 11.0-b15
System: Windows XP version 5.1 running on x86; Cp1250; cs_CZ (nb)

I am sorry, but I have to reopen this issue.
I can still reproduce it on Win XP and I just reproduced it on another computer with Ubuntu. 

I started NB with fresh userdir, created new project and immediatelly imported it into CVS repository. I obtanied the
same result as shown on the picture attached (cvs.gif) - only one menu option on the project root node (others work fine).

One change after the suggested fix: restarting NB DOES solve the problem now.

Additional info:
- Project can be saved in any directory to reproduce this problem (it is not necessary to be in the C:\Documents and
Settings\pavel\My Documents\NetBeansProjects)
- It does not seem to be problem of a repository, the same behaviour I noticed on Peter's :pserver: repo, as well as on
my :local: one.