This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 146659 - IllegalArgumentException: <none>
Summary: IllegalArgumentException: <none>
Status: RESOLVED DUPLICATE of bug 146670
Alias: None
Product: java
Classification: Unclassified
Component: Compiler (show other bugs)
Version: 6.x
Hardware: All All
: P3 blocker (vote)
Assignee: Dusan Balek
URL: http://statistics.netbeans.org/except...
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-09 15:17 UTC by rajivderas
Modified: 2008-11-07 05:08 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter: 108687


Attachments
stacktrace (2.81 KB, text/plain)
2008-09-09 15:17 UTC, rajivderas
Details
log file (47.06 KB, text/plain)
2008-09-09 15:19 UTC, rajivderas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rajivderas 2008-09-09 15:17:45 UTC
Build: NetBeans IDE Dev (Build 200809081401)
VM: Java HotSpot(TM) Client VM, 11.0-b11, Java(TM) SE Runtime Environment, 1.6.0_10-beta-b21
OS: Windows XP, 5.1, x86

User Comments: 
tried to use Collections.sort()

Stacktrace: 
java.lang.IllegalArgumentException: <none>
        at com.sun.tools.javac.model.JavacTypes.getWildcardType(JavacTypes.java:209)
        at org.netbeans.api.java.source.TypeMirrorHandle.resolve(TypeMirrorHandle.java:307)
        at org.netbeans.api.java.source.TypeMirrorHandle.resolve(TypeMirrorHandle.java:263)
        at org.netbeans.api.java.source.TypeMirrorHandle.resolve(TypeMirrorHandle.java:294)
        at org.netbeans.api.java.source.TypeMirrorHandle.resolve(TypeMirrorHandle.java:263)
        at org.netbeans.api.java.source.TypeMirrorHandle.resolve(TypeMirrorHandle.java:218)
Comment 1 rajivderas 2008-09-09 15:17:54 UTC
Created attachment 69414 [details]
stacktrace
Comment 2 rajivderas 2008-09-09 15:19:01 UTC
Created attachment 69415 [details]
log file
Comment 3 Dusan Balek 2008-09-10 09:45:45 UTC
The same case as described in #146670.

*** This issue has been marked as a duplicate of 146670 ***
Comment 4 sunbiz 2008-11-06 17:18:48 UTC
Removing [65cat] from summary since this issue is duplicate of already submitted Issue 146670