This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 151920 - Restore opened projects, folders when changing project groups
Summary: Restore opened projects, folders when changing project groups
Status: RESOLVED DUPLICATE of bug 62249
Alias: None
Product: projects
Classification: Unclassified
Component: Generic Infrastructure (show other bugs)
Version: 6.x
Hardware: All All
: P3 blocker (vote)
Assignee: Jesse Glick
URL:
Keywords:
: 190503 198019 (view as bug list)
Depends on:
Blocks: 168578
  Show dependency tree
 
Reported: 2008-10-30 22:57 UTC by tjquinn
Modified: 2011-10-11 22:13 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tjquinn 2008-10-30 22:57:09 UTC
When I change project groups, I want NB to have remembered the projects and folders that I had expanded in the explorer
when I last closed that project group and restore them to the same state when I return to that project group.  

Currently when I return to a project group all projects in it are displayed unexpanded.  I have to expand them again
myself to return to the previous state.  

I really like the project groups feature, and very often I have to jump among several different ones.  It would be a big
help in re-establishing my "mental context" (what I was in the middle of doing the last time in a given project group)
if the IDE would restore this state for me.
Comment 1 Antonin Nebuzelsky 2010-03-29 14:10:52 UTC
Change of default owner.
Comment 2 Jesse Glick 2011-05-24 19:00:45 UTC
*** Bug 198019 has been marked as a duplicate of this bug. ***
Comment 3 Marian Mirilovic 2011-05-25 08:07:41 UTC
*** Bug 190503 has been marked as a duplicate of this bug. ***
Comment 4 Jesse Glick 2011-10-11 22:13:56 UTC

*** This bug has been marked as a duplicate of bug 62249 ***