This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 153079 - Graphical representation of grouped projects
Summary: Graphical representation of grouped projects
Status: RESOLVED DUPLICATE of bug 235343
Alias: None
Product: projects
Classification: Unclassified
Component: Generic Projects UI (show other bugs)
Version: 6.x
Hardware: All All
: P3 blocker (vote)
Assignee: Milos Kleint
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-12 21:53 UTC by vincesheard
Modified: 2013-10-23 10:46 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vincesheard 2008-11-12 21:53:13 UTC
We are a partner who is building a product on NB. 
Many of our projects are what you refer to as aggregate projects. We would like to see this represented in the project 
window as a group of sub projects
Comment 1 vincesheard 2008-11-12 21:55:42 UTC
1.	Graphical representation of grouped projects. 
a.	This could be achieved by allowing Projects to be nested into a tree view. The root of the tree would be the 
group name of the projects and could have a different Icon. When operating with the group project as a main project, 
actions would affect the whole group of projects within the tree.
Comment 2 markiewb 2013-01-02 12:34:08 UTC
FYI: There was plugin http://plugins.netbeans.org/plugin/4647/project-groups (at the time of 6.x) which showed the project groups as a tree in another topcomponent.
Comment 3 Martin Kozeny 2013-10-23 10:46:40 UTC

*** This bug has been marked as a duplicate of bug 235343 ***