This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 154263 - [65cat] NullPointerException at org.netbeans.modules.project.ant.AntBasedProjectFactorySingleton.getProjectFor
Summary: [65cat] NullPointerException at org.netbeans.modules.project.ant.AntBasedProj...
Status: RESOLVED DUPLICATE of bug 146852
Alias: None
Product: projects
Classification: Unclassified
Component: Ant Project (show other bugs)
Version: 6.x
Hardware: All All
: P3 blocker (vote)
Assignee: Milan Kubec
URL: http://statistics.netbeans.org/except...
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-01 13:19 UTC by misterm
Modified: 2009-04-17 17:19 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Exception Reporter: 9637


Attachments
stacktrace (1.49 KB, text/plain)
2008-12-01 13:20 UTC, misterm
Details

Note You need to log in before you can comment on or make changes to this bug.
Description misterm 2008-12-01 13:19:59 UTC
Build: NetBeans IDE 6.5 RC1 (Build 200810171318)
VM: Java HotSpot(TM) Client VM, 10.0-b19, Java(TM) SE Runtime Environment, 1.6.0_04-b12
OS: Windows XP, 5.1, x86

User Comments:
misterm: Just trying to open a web project

GUEST: Initial boot of Netbeans.

GUEST: I was starting Netbeans IDE 6.1 for the first time after instalation

GUEST: Opening netbeans 6.1 IDE

misterm: Just trying to open a web project



Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.project.ant.AntBasedProjectFactorySingleton.getProjectFor(AntBasedProjectFactorySingleton.java:304)
        at org.netbeans.spi.project.support.ant.SourcesHelper.getProject(SourcesHelper.java:473)
        at org.netbeans.spi.project.support.ant.SourcesHelper.remarkExternalRoots(SourcesHelper.java:586)
        at org.netbeans.spi.project.support.ant.SourcesHelper.registerExternalRoots(SourcesHelper.java:579)
        at org.netbeans.spi.project.support.ant.SourcesHelper.registerExternalRoots(SourcesHelper.java:520)
        at org.netbeans.modules.web.project.WebSources$.run(WebSources.java:144)
Comment 1 misterm 2008-12-01 13:20:05 UTC
Created attachment 74344 [details]
stacktrace
Comment 2 Andrey Yamkovoy 2009-04-17 10:28:12 UTC
Should not reproduce anymore after the following Jesse's change in the Web.Project:
http://hg.netbeans.org/main/diff/23a442bff758/web.project/src/org/netbeans/modules/web/project/WebSources.java
Please reopen with new stacktrace if still reproducible.
Comment 3 Jesse Glick 2009-04-17 17:19:10 UTC
.
Comment 4 Jesse Glick 2009-04-17 17:19:42 UTC

*** This issue has been marked as a duplicate of 146852 ***