This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 155204 - NullPointerException at org.netbeans.modules.form.BindingCustomizer.updateColumnSelector
Summary: NullPointerException at org.netbeans.modules.form.BindingCustomizer.updateCol...
Alias: None
Product: guibuilder
Classification: Unclassified
Component: Code (show other bugs)
Version: 8.0
Hardware: All All
: P3 blocker (vote)
Assignee: issues@guibuilder
: 164206 (view as bug list)
Depends on:
Reported: 2008-12-11 08:18 UTC by rcasha
Modified: 2016-08-04 14:10 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter: 144229

stacktrace (3.66 KB, text/plain)
2008-12-11 08:18 UTC, rcasha
A minimal test case. (18.28 KB, application/zip)
2014-06-17 14:11 UTC, the_noid

Note You need to log in before you can comment on or make changes to this bug.
Description rcasha 2008-12-11 08:18:46 UTC
Build: NetBeans IDE 6.5 (Build 200811100001)
VM: Java HotSpot(TM) Client VM, 11.0-b15, Java(TM) SE Runtime Environment, 1.6.0_10-b33
OS: Linux, 2.6.27-9-server, i386

User Comments:
rcasha: Opening Bind Table window; table was already bound to some properties

        at org.netbeans.modules.form.BindingCustomizer.updateColumnSelector(
        at org.netbeans.modules.form.BindingCustomizer.treeComboActionPerformed(
        at org.netbeans.modules.form.BindingCustomizer.access$1300(
        at org.netbeans.modules.form.BindingCustomizer$FormListener.actionPerformed(
        at javax.swing.JComboBox.fireActionEvent(
        at javax.swing.JComboBox.setSelectedItem(
Comment 1 rcasha 2008-12-11 08:18:54 UTC
Created attachment 74836 [details]
Comment 2 Jiri Vagner 2008-12-16 11:56:23 UTC
Thank you for your report. I tried to add jtable into jframe and bind tree properties of that table with some form
properties. After each binding step I tried to open and close bind dialog many times. Unfortunalely I was not able to
reproduce your issue. Can you please help us more and attach a few steps to reproduce?
Comment 3 pribyl 2009-01-08 15:38:44 UTC
Reporter didn't provided required information for more than 14 days. 
I'm closing this issue as worksforme, as we are not able to reproduce it with available information. 
Rcasha, feel free to reopen when you face the problem again but attach the additional info.

thank you for report
Comment 4 Jan Stola 2009-05-22 17:18:32 UTC
*** Issue 164206 has been marked as a duplicate of this issue. ***
Comment 5 the_noid 2014-06-17 14:11:37 UTC
Created attachment 147705 [details]
A minimal test case.

I just ran into the same (or a similar) problem with an up-to-date Netbeans 8, and created a test-case.
It seems to be a problem with "recursive" generics.