Bug 156124 - Editor bookmarks view
Summary: Editor bookmarks view
Status: RESOLVED FIXED
Alias: None
Product: editor
Classification: Unclassified
Component: Navigation (show other bugs)
Version: 5.x
Hardware: All All
: P1 blocker (vote)
Assignee: Miloslav Metelka
URL:
Keywords:
: 113758 160368 210701 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-12-29 10:48 UTC by mco
Modified: 2012-06-06 13:13 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mco 2008-12-29 10:48:51 UTC
It would be very useful to have view with all bookmarks from opened projects visible in one list, so we could navigate
to them no mater which file we are editing now.
Comment 1 Vitezslav Stejskal 2009-01-02 16:05:07 UTC
Sounds useful, thanks!
Comment 2 Miloslav Metelka 2012-03-26 22:54:58 UTC
Initial commit:
http://hg.netbeans.org/jet-main/rev/09651e9eb739
Comment 3 Miloslav Metelka 2012-04-02 14:27:36 UTC
Improved bookmarks nodes sync:
http://hg.netbeans.org/jet-main/rev/b85903a583be
Comment 4 Quality Engineering 2012-04-03 11:14:48 UTC
Integrated into 'main-golden', will be available in build *201204030400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/b85903a583be
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #156124 - Editor bookmarks view - improved bookmark nodes sync.
Comment 5 Miloslav Metelka 2012-04-10 12:53:30 UTC
key chooser and history popup:
http://hg.netbeans.org/jet-main/rev/f1fe33ceb2aa
Comment 6 Miloslav Metelka 2012-04-11 08:15:29 UTC
*** Bug 210701 has been marked as a duplicate of this bug. ***
Comment 7 Quality Engineering 2012-04-12 10:00:34 UTC
Integrated into 'main-golden', will be available in build *201204120400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/f1fe33ceb2aa
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #156124 - Editor bookmarks view - key chooser and history popup.
Comment 8 Miloslav Metelka 2012-06-06 13:13:03 UTC
*** Bug 160368 has been marked as a duplicate of this bug. ***
Comment 9 Miloslav Metelka 2012-06-06 13:13:47 UTC
*** Bug 113758 has been marked as a duplicate of this bug. ***