This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 156595 - Go To Type && Go To File && Go To Symbol does not participate in JumpList
Summary: Go To Type && Go To File && Go To Symbol does not participate in JumpList
Status: RESOLVED DUPLICATE of bug 122507
Alias: None
Product: editor
Classification: Unclassified
Component: Navigation (show other bugs)
Version: 6.x
Hardware: All All
: P3 blocker (vote)
Assignee: issues@editor
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-12 09:46 UTC by Vladimir Voskresensky
Modified: 2009-04-28 09:39 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Voskresensky 2009-01-12 09:46:01 UTC
When user opens file using "Go To Type" or "Go To File" actions => Alt+LEFT/RIGHT actions does not work => not possible
to return the the previous cursor position
Comment 1 Jaromir Uhrik 2009-01-12 13:49:43 UTC
Passing to the proper component - please evaluate. Thanks.
Comment 2 Vitezslav Stejskal 2009-01-15 11:52:10 UTC
What files were you navigating through, C++, java, others?
Comment 3 Vladimir Voskresensky 2009-01-15 13:29:51 UTC
Any file. Looks like the problem is that infrastructure should use JumpList.checkAddEntry before performing "go to" action
Comment 4 Alexei Mokeev 2009-04-21 10:34:24 UTC
Faced the same problem. Some more details:
1. Start new session with empty navigation history.
- in this case files opened by Go To File and Go To Type are not added to the history.

2. Add something(item 1) to the history by using Navigate->Go To Source 

- in this case for files opened by Go To File 'Back' is enabled, but always points to "item 1"

Looks strange ;)
Comment 5 Vladimir Voskresensky 2009-04-21 10:38:52 UTC
the same for Go To Symbol
Comment 6 Sergey Petrov 2009-04-28 09:39:18 UTC
in my opinion if issue 122507 is valid, this one is a duplicate. just a specific cases for files opening.

*** This issue has been marked as a duplicate of 122507 ***