This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 157690 - Netbeans crashes on KDE 4.2
Summary: Netbeans crashes on KDE 4.2
Alias: None
Product: platform
Classification: Unclassified
Component: Window System (show other bugs)
Version: 6.x
Hardware: PC Linux
: P2 blocker (vote)
Assignee: mslama
Keywords: RELNOTE
Depends on:
Reported: 2009-01-30 21:44 UTC by cbourque
Modified: 2009-05-15 18:21 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter:

Execution output (1.86 KB, text/plain)
2009-01-30 21:47 UTC, cbourque

Note You need to log in before you can comment on or make changes to this bug.
Description cbourque 2009-01-30 21:44:09 UTC
Everytime I try to use Netbeans 6.5 on KDE 4.2 it crashes as soon as I start playing with the windows...
Comment 1 cbourque 2009-01-30 21:47:23 UTC
Created attachment 76396 [details]
Execution output
Comment 2 cbourque 2009-01-30 21:51:15 UTC
There is no additionnal output or log, no jvm crash log either... My Linux distribution is openSUSE 11.1 running with
Java 1.6.0_11 (64-Bit)...
Comment 3 cbourque 2009-01-30 22:25:34 UTC
Another thing: if I launch Netbeans as root the problem doesn't happen (no crash)!
Comment 4 gqman69 2009-02-01 21:40:43 UTC
Ok, I've got the same problem but on Gentoo x86_64.

This seems to be related to KDE4 since it doesn't happen in Gnome or KDE 3.5.10.

If I run NetBeans 6.5 as root, it works fine.

Running it as a user makes NetBeans "Abort" as described by cbourque.

I have tested xorg-server 1.5 and 1.6RC2, libxcb 1.1.90, 1.1.91, 1.1.92 and finally 1.1.93.

I have tried BackingStore "true", "false".

I have tried the sed hack for Java.

I have tried the LIBXCB_ALLOW_SLOPPY_LOCK=1.

The problem here is that no stck trace is provided, no specific error is printed.
Comment 5 cbourque 2009-02-02 19:25:00 UTC
I've just installed Patch2 for Netbeans 6.5 and the behavior is still the same...
Comment 6 Stanislav Aubrecht 2009-02-04 10:06:55 UTC
cbourque, did you by any chance install netbeans using sudo?
Comment 7 gqman69 2009-02-04 16:07:53 UTC
Well, I didn't. In fact I installed the generic version of netbeans. First as root into my /opt then for debugging this
issue as a user in my ~/tmp/netbeans.

It doesn't change anything. Behavior still the same.

I have now tried JDK 1.7 beta.

This is really weird as it works perfectly on my KDE 3.5.10.

On KDE 4.2 as a user, it "Abort" by just dragging a tab (like Projects) around for a while. No messages is given by the
JVM or netbeans.

Can anyone tell me if there is a flag or something I can use to debug this (from netbeans standpoint) as I have tried
strace with no success.
Comment 8 cbourque 2009-02-04 19:44:18 UTC
saubrecht, nope it was installed using a regular user...
Comment 9 Stanislav Aubrecht 2009-02-05 10:08:47 UTC
cbourque, please go to 'tools - options - miscellaneous - appearance' and turn 'drag window image' and 'transparent
floating windows' off, pls
Comment 10 gqman69 2009-02-05 16:53:42 UTC
Well turning off transparent and image seems to work.

But what is the cause of this? Why would it work when running in root?
Comment 11 cbourque 2009-02-05 18:56:30 UTC
saubrecht, the "hack" seems to fix the problem but the cause is still to be determined...
Comment 12 Stanislav Aubrecht 2009-02-06 09:21:31 UTC
netbeans uses Java Native Access library to enable window transparency by calling some native code. this seems to be
badly broken under kde 4.2
Comment 13 Stanislav Aubrecht 2009-02-06 10:33:44 UTC
i didn't find any issue reported against JNA lib that would explain the crash.
reassigning to mslama to reproduce the issue and/or disable JNA with KDE 4.2 if possible
Comment 14 mslama 2009-02-06 12:54:09 UTC
I have Ubuntu 8.10 with KDE 4.1.4. I do not have KDE 4.2 now. With KDE 4.1.4 it works fine. I moved with views around
for 1 minute. I tried multiple view and dragged them elsewhere. Transparency is enabled. Could you try some jna sample
with transparency? ( We use jna 3.0.9 in dev builds from Dec 9 2008. I used Sun JDK 6u12 and 7 b45.

It looks like problem of KDE 4.2. Do you run IDE from console or from desktop shortcut? Anything in
$HOME/.xsession-errors? I have 32bit system and 32bit JDK. You both have 64bit and use 64bit JDK right? I have another
machine with 64bit Ubuntu so I could try to install KDE there and test. I plan to update to dev version of Ubuntu which
should have latest KDE or try to install 4.2 on Ubuntu 8.10.
Comment 15 mslama 2009-02-06 12:56:13 UTC
Please also try latest development build if it makes any difference.
Comment 16 mslama 2009-02-06 13:10:51 UTC
I checked and did not find any similar example in examples.jar from jna so just use IDE to reproduce this problem.
Comment 17 mslama 2009-02-06 13:21:06 UTC
If JVM process crashes there should be file hs-*.log in working directory and also core file (if you allowed it in
ulimit (Use ulimit -a to see if creation of core file is allowed.)
Comment 18 cbourque 2009-02-06 15:54:57 UTC
ok I got the core dump but it's pretty big (300MB), is there anything useful I can get out of this file?
Comment 19 mslama 2009-02-06 15:58:34 UTC
Is there hs*.log file from JVM?
Comment 20 cbourque 2009-02-06 16:08:20 UTC
nope, no hs*.log file...

here's the backtrace of the core dump:

Core was generated by `/usr/lib64/jvm/java-1.6.0-sun-1.6.0/bin/java -Djdk.home=/usr/lib64/jvm/java-1.6'.
Program terminated with signal 6, Aborted.
#0  0x00007fe5214f1645 in raise () from /lib64/
(gdb) bt
#0  0x00007fe5214f1645 in raise () from /lib64/
#1  0x00007fe5214f2c33 in abort () from /lib64/
#2  0x00007fe521533140 in ?? () from /lib64/
#3  0x00007fe4fe4b7b2c in Java_com_sun_jna_Memory_free () from /tmp/jna4620875296788378045.tmp
#4  0x00007fe51cca31ad in ?? ()
#5  0x00007fe510753490 in ?? ()
#6  0x0000000000000000 in ?? ()

it seems to be JNA related...
Comment 21 mslama 2009-02-06 16:36:58 UTC
I filed Please test latest dev build with jna 3.0.9 - it is last
released version. I will try to reproduce it here. Could you register on and add yourself to CC of that
issue? If they will ask for more info it will be faster. I am not sure if I will be able to reproduce it here.
Comment 22 mslama 2009-02-26 14:17:57 UTC
It is apparently KDE issue. I provided info to jna about our user case and will help with identification as I can so
that it can be passed to KDE. Only workaround is to disable transparency if you want to drag tabs. For more details
follow link to jna issue I filed given above.

Summary: It happens on KDE 4.2 and 64bit OS/JDK. I did not see it with KDE 4.1.x and 32bit JDK. I installed KDE 4.2 to
Ubuntu Intrepid 8.10 on NVidia driver with Compiz.
Comment 23 mslama 2009-05-15 10:20:30 UTC
It looks like it is fixed in KDE 4.2.2. I tested on Ubuntu 9.04, JDK 6u13 b03 installed from package and JDK 6u14 b07
installed from Linux installer and IDE does not crash when I drag views around. Please test it too to verify. (Both JDKs
are 64bit.)
Comment 24 cbourque 2009-05-15 18:21:45 UTC
Yep it works!