This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 159589 - DnD to external editor / explorer not working
Summary: DnD to external editor / explorer not working
Status: RESOLVED DUPLICATE of bug 139680
Alias: None
Product: platform
Classification: Unclassified
Component: Data Systems (show other bugs)
Version: 6.x
Hardware: All All
: P2 blocker (vote)
Assignee: Jiri Skrivanek
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-04 10:06 UTC by elishae
Modified: 2009-03-18 10:08 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description elishae 2009-03-04 10:06:18 UTC
Test Scenario:
1. Open a project.
2. Select a file in Files/Project and drag it out to desktop/any explorer window.

Expected: 
File should be copied/moved based.

Observed: 
Windows Error Msg Dialog stating "Cannot Copy File: The file name you specified is not valid or too long.Specify a
different file name.


Test Scenario:
1. Open Project
2. Select a file and drag it to external editor window (say notepad).

Expected: 
File should be opened in the target editor. (in this case notepad)

Observed:
Mouse icon "does" change representing that the editor(notepad) window  is valid drop target.
But "nothing" happens after releasing the mouse button.

This is happening even in 6.5. However, it used to work in 6.0 and earlier.
Comment 1 elishae 2009-03-04 10:09:02 UTC
Also please note that 'dragging from explorer to netbeans' still works.
But NOT the other way round as mentioned.
Comment 2 Andrei Chistiakov 2009-03-04 16:36:59 UTC
Reassigning to projects
Comment 3 Milos Kleint 2009-03-18 10:02:47 UTC
not related to project infrastructure, reassigning to datasystems that probably defined the drag& drop content
Comment 4 Jiri Skrivanek 2009-03-18 10:08:33 UTC

*** This issue has been marked as a duplicate of 139680 ***