This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 159680 - javax.swing.text.BadLocationException: Invalid offset=1 not within <0, 0>
Summary: javax.swing.text.BadLocationException: Invalid offset=1 not within <0, 0>
Status: RESOLVED WORKSFORME
Alias: None
Product: editor
Classification: Unclassified
Component: Painting & Printing (show other bugs)
Version: 6.x
Hardware: All All
: P4 blocker (vote)
Assignee: Miloslav Metelka
URL: http://statistics.netbeans.org/except...
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-05 13:32 UTC by rajivderas
Modified: 2012-10-26 13:19 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Exception Reporter: 135137


Attachments
stacktrace (4.40 KB, text/plain)
2009-03-05 13:32 UTC, rajivderas
Details
stacktrace (2.79 KB, text/plain)
2010-05-26 12:17 UTC, Vladimir Voskresensky
Details
stacktrace (2.79 KB, text/plain)
2010-05-26 12:20 UTC, Vladimir Voskresensky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rajivderas 2009-03-05 13:32:36 UTC
Build: NetBeans IDE 6.5 (Build 200811100001)
VM: OpenJDK Client VM, 14.0-b10, Java(TM) SE Runtime Environment, 1.6.0_14-ea-b01
OS: Windows XP, 5.1, x86

Stacktrace: 
javax.swing.text.BadLocationException: Invalid offset=1 not within <0, 0>
        at org.netbeans.modules.editor.lib2.DocUtils.checkOffsetValid(DocUtils.java:192)
        at org.netbeans.modules.editor.lib2.DocUtils.checkOffsetValid(DocUtils.java:187)
        at org.netbeans.modules.editor.lib2.DocUtils.getRowStart(DocUtils.java:64)
        at org.netbeans.modules.editor.lib2.highlighting.CaretBasedBlockHighlighting$CaretRowHighlighting.getCurrentBlockPositions(CaretBasedBlockHighlighting.java:299)
        at org.netbeans.modules.editor.lib2.highlighting.CaretBasedBlockHighlighting.updateLineInfo(CaretBasedBlockHighlighting.java:171)
        at org.netbeans.modules.editor.lib2.highlighting.CaretBasedBlockHighlighting.<init>(CaretBasedBlockHighlighting.java:111)
Comment 1 rajivderas 2009-03-05 13:32:41 UTC
Created attachment 77765 [details]
stacktrace
Comment 2 Vitezslav Stejskal 2009-03-11 18:40:55 UTC
Any steps for reproducing this? Thanks
Comment 3 Marian Mirilovic 2010-04-13 09:49:32 UTC
49 duplicates, but none of them reported for NB 6.8 or later
Comment 4 Vladimir Voskresensky 2010-05-26 12:17:32 UTC
Created attachment 99490 [details]
stacktrace
Comment 5 Vladimir Voskresensky 2010-05-26 12:20:33 UTC
Created attachment 99491 [details]
stacktrace
Comment 6 David Strupl 2012-10-25 13:39:16 UTC
Bug prior to 7.0, not touched for the last 2 years --> P4.
Comment 7 David Strupl 2012-10-26 13:19:00 UTC
Does not happen in 7.2 or newer. Closing as works for me.