This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 160273 - NullPointerException at org.netbeans.modules.editor.MainMenuAction.setMenu
Summary: NullPointerException at org.netbeans.modules.editor.MainMenuAction.setMenu
Status: RESOLVED FIXED
Alias: None
Product: editor
Classification: Unclassified
Component: -- Other -- (show other bugs)
Version: 6.x
Hardware: All All
: P3 blocker (vote)
Assignee: issues@editor
URL: http://statistics.netbeans.org/except...
Keywords:
: 156941 159342 159987 161042 162246 162444 162825 163351 163501 166237 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-03-13 17:50 UTC by Oleg Khokhlov
Modified: 2009-10-24 06:11 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter: 147504


Attachments
stacktrace (1.66 KB, text/plain)
2009-03-13 17:50 UTC, Oleg Khokhlov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oleg Khokhlov 2009-03-13 17:50:20 UTC
Build: NetBeans IDE Dev (Build 200903110259)
VM: Java HotSpot(TM) Client VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Windows XP, 5.1, x86

User Comments:
ovk: just started IDE



Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.editor.MainMenuAction.setMenu(MainMenuAction.java:199)
        at org.netbeans.modules.editor.MainMenuAction.resultChanged(MainMenuAction.java:112)
        at org.openide.util.lookup.SimpleProxyLookup.checkLookup(SimpleProxyLookup.java:111)
        at org.openide.util.lookup.SimpleProxyLookup.lookup(SimpleProxyLookup.java:152)
        at org.netbeans.modules.openide.windows.GlobalActionContextImpl.propertyChange(GlobalActionContextImpl.java:134)
        at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:339)
Comment 1 Oleg Khokhlov 2009-03-13 17:50:31 UTC
Created attachment 78158 [details]
stacktrace
Comment 2 Vitezslav Stejskal 2009-03-20 12:24:54 UTC
local changeset: f5d9f414d477
Comment 3 Quality Engineering 2009-03-21 20:25:14 UTC
Integrated into 'main-golden', will be available in build *200903211401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/f5d9f414d477
User: Vita Stejskal <vstejskal@netbeans.org>
Log: #160273: delaying listeners initialization so that the subclasses have a chance to finish their initialization
Comment 4 Vitezslav Stejskal 2009-03-23 12:43:45 UTC
*** Issue 159987 has been marked as a duplicate of this issue. ***
Comment 5 Jesse Glick 2009-03-27 01:45:27 UTC
I have a build from today (25f4e360901b) and got

java.lang.AssertionError: Got null return from getMenuPresenter in
org.netbeans.modules.editor.MainMenuAction$ToggleCommentAction@3f8a3e
	at org.netbeans.modules.editor.MainMenuAction.setMenu(MainMenuAction.java:202)
Comment 6 Vitezslav Stejskal 2009-03-31 09:52:55 UTC
Right. There was one more LookupListener initialized from MainMenuAction's superclasse's constructor.
http://hg.netbeans.org/jet-main/rev/169f0f03ec44
Comment 7 Quality Engineering 2009-04-02 07:31:50 UTC
Integrated into 'main-golden', will be available in build *200904020200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/169f0f03ec44
User: Vita Stejskal <vstejskal@netbeans.org>
Log: #160273 - do not start listening on global context until it's first used
Comment 8 Vitezslav Stejskal 2009-04-06 12:58:38 UTC
*** Issue 161042 has been marked as a duplicate of this issue. ***
Comment 9 Vitezslav Stejskal 2009-04-06 13:00:27 UTC
*** Issue 159342 has been marked as a duplicate of this issue. ***
Comment 10 Vitezslav Stejskal 2009-04-06 13:02:10 UTC
*** Issue 156941 has been marked as a duplicate of this issue. ***
Comment 11 Vitezslav Stejskal 2009-04-20 10:09:23 UTC
*** Issue 162825 has been marked as a duplicate of this issue. ***
Comment 12 Vitezslav Stejskal 2009-04-20 13:09:39 UTC
*** Issue 162444 has been marked as a duplicate of this issue. ***
Comment 13 Vitezslav Stejskal 2009-04-20 13:43:43 UTC
*** Issue 162246 has been marked as a duplicate of this issue. ***
Comment 14 Vitezslav Stejskal 2009-04-22 15:46:59 UTC
*** Issue 163351 has been marked as a duplicate of this issue. ***
Comment 15 Vitezslav Stejskal 2009-04-24 12:25:04 UTC
*** Issue 163501 has been marked as a duplicate of this issue. ***
Comment 16 Vitezslav Stejskal 2009-10-02 10:47:01 UTC
*** Issue 166237 has been marked as a duplicate of this issue. ***