This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 162607 - Present featured/hot projects to a user
Summary: Present featured/hot projects to a user
Status: VERIFIED FIXED
Alias: None
Product: connecteddeveloper
Classification: Unclassified
Component: Team Framework (show other bugs)
Version: 6.x
Hardware: All All
: P2 blocker (vote)
Assignee: Petr Dvorak
URL:
Keywords:
: 169042 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-04-14 16:16 UTC by Petr Dvorak
Modified: 2009-11-10 03:33 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
Exception Reporter:


Attachments
Featured projects in "Open Kenai Project" dialog (35.40 KB, image/png)
2009-08-19 11:34 UTC, Ondrej Langr
Details
screenshot (141.00 KB, image/png)
2009-09-01 22:15 UTC, Petr Dvorak
Details
screenshot (71.92 KB, image/png)
2009-09-01 22:16 UTC, Petr Dvorak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Dvorak 2009-04-14 16:16:21 UTC
It would be nice if the "Open Kenai Project" dialog contained tabs "Featured", "Freshly baked" and "Search Project", so
that user is presented with featured and new projects, and not only with the ability to search a project (he/she has to
know the name first).

The last tab would contain the very same content as the dialog contains now, others would be just lists of 10-20 projects.

This certainly requires a new web API - http://kenai.com/jira/browse/KENAI-448
Comment 1 Petr Dvorak 2009-07-14 14:08:31 UTC
IMO this is more relevant since the "Open Kenai Project" action is in the main menu - at least some "hot" projects
should be advertised in the dialog...
Comment 2 Jan Becicka 2009-08-06 07:55:05 UTC
*** Issue 169042 has been marked as a duplicate of this issue. ***
Comment 3 Jan Becicka 2009-08-06 10:49:24 UTC
this issue cannot be implemented without KENAI-448.
Comment 4 Ondrej Langr 2009-08-14 11:20:23 UTC
How likely is it that KENAI-448 will be implemented? I'm a bit hesitant to spend time on UI design for this which would
then not be used. 
Comment 5 Petr Dvorak 2009-08-14 16:41:30 UTC
There is a development in the issue 448 - JB says the functionality is already there, it is just ndocumented for some
reason:

> This is already possible in the existing API.
>
> http://kenai.com/api/projects.json?&filter=featured
>
> Will return the 5 featured projects.
>
> http://kenai.com/api/projects.json?&filter=recent
>
> Will return the 5 most recent projects created on the site.
>
> It use to be in the documentation, but I don't see it in the most recent Docs on the API project.
Comment 6 Ondrej Langr 2009-08-19 11:34:08 UTC
Created attachment 86444 [details]
Featured projects in "Open Kenai Project" dialog
Comment 7 Ondrej Langr 2009-08-19 11:34:32 UTC
UI design attached, reassigning for implementation. 
Comment 8 Quality Engineering 2009-08-21 06:17:23 UTC
Integrated into 'main-golden', will be available in build *200908210201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/cbf3aa1b76e0
User: Jan Becicka <jbecicka@netbeans.org>
Log: #162607: support for recent projects. Use "&filter=recent" and "&filter=featured" as search patterns
Comment 9 Petr Dvorak 2009-09-01 22:14:43 UTC
Almost implemented - I didn't manage to add the images and I am not sure to what extent they are doable (the component
uses some "nasty" swing hacks)...

http://hg.netbeans.org/cdev/rev/4cc188bd64c9

If you feel strongly about the images, please open separate issue (and probably assign it to "saubrecht" directly)...
Comment 10 Petr Dvorak 2009-09-01 22:15:43 UTC
Created attachment 86940 [details]
screenshot
Comment 11 Petr Dvorak 2009-09-01 22:16:14 UTC
Created attachment 86941 [details]
screenshot
Comment 12 Quality Engineering 2009-09-04 03:51:59 UTC
Integrated into 'main-golden', will be available in build *200909032054* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/4cc188bd64c9
User: joshis@netbeans.org
Log: #162607 - Present featured/hot projects to a user
Comment 13 Petr Dvorak 2009-10-26 15:39:59 UTC
Verified, done for 6.8. Open Kenai project dialog contains featured/recent project tabs.