This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 163295 - InterruptedException at java.lang.Object.wait
Summary: InterruptedException at java.lang.Object.wait
Status: RESOLVED FIXED
Alias: None
Product: projects
Classification: Unclassified
Component: Generic Infrastructure (show other bugs)
Version: 6.x
Hardware: All All
: P2 blocker with 1 vote (vote)
Assignee: David Simonek
URL: http://statistics.netbeans.org/except...
Keywords:
Depends on: 174274
Blocks: 162612
  Show dependency tree
 
Reported: 2009-04-21 17:53 UTC by Jesse Glick
Modified: 2010-04-08 21:42 UTC (History)
19 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter: 144924


Attachments
stacktrace (987 bytes, text/plain)
2009-04-21 17:53 UTC, Jesse Glick
Details
stacktrace (987 bytes, text/plain)
2009-04-22 13:30 UTC, smithd1
Details
stacktrace (987 bytes, text/plain)
2009-04-23 14:49 UTC, _ tboudreau
Details
stacktrace (1.10 KB, text/plain)
2009-04-28 15:01 UTC, rajivderas
Details
stacktrace (1.09 KB, text/plain)
2009-04-29 15:39 UTC, Michal Mocnak
Details
stacktrace (987 bytes, text/plain)
2009-04-30 16:30 UTC, Filip Zamboj
Details
stacktrace (987 bytes, text/plain)
2009-05-05 08:29 UTC, Erno Mononen
Details
stacktrace (1.22 KB, text/plain)
2009-05-15 15:46 UTC, Vojtech Sigler
Details
stacktrace (987 bytes, text/plain)
2009-05-18 09:46 UTC, Michal Mocnak
Details
stacktrace (987 bytes, text/plain)
2009-05-18 14:11 UTC, Filip Zamboj
Details
stacktrace (987 bytes, text/plain)
2009-05-19 22:19 UTC, Michal Mocnak
Details
stacktrace (1.13 KB, text/plain)
2009-08-13 13:52 UTC, mohhmekk
Details
stacktrace (2.36 KB, text/plain)
2010-02-23 16:50 UTC, Jesse Glick
Details
stacktrace (2.36 KB, text/plain)
2010-02-28 12:53 UTC, Jan Lahoda
Details
stacktrace (2.37 KB, text/plain)
2010-03-01 17:39 UTC, Jesse Glick
Details
stacktrace (2.37 KB, text/plain)
2010-03-24 17:50 UTC, Alexander Simon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2009-04-21 17:53:28 UTC
Build: NetBeans IDE Dev (Build 090420)
VM: Java HotSpot(TM) Client VM, 11.0-b16, Java(TM) SE Runtime Environment, 1.6.0_11-b03
OS: Linux, 2.6.27-11-generic, i386

User Comments:
jglick: Opened contrib/apisupport.projectinspector.

nbnathan: adding JBI module to composite application

GUEST: Opening an API support project (maven.samples).



Stacktrace: 
java.lang.InterruptedException
        at java.lang.Object.wait(Object.java:0)
        at java.lang.Object.wait(Object.java:485)
        at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:244)
        at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:227)
        at org.openide.util.Mutex.readAccess(Mutex.java:327)
        at org.netbeans.api.project.ProjectManager.findProject(ProjectManager.java:227)
Comment 1 Jesse Glick 2009-04-21 17:53:35 UTC
Created attachment 80618 [details]
stacktrace
Comment 2 Jesse Glick 2009-04-21 17:59:05 UTC
I guess caused by attempted fix of issue #162612. Perhaps using Thread.interrupt is not going to work?
Comment 3 smithd1 2009-04-22 13:30:45 UTC
Build: NetBeans IDE Dev (Build 200904171401)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Windows XP, 5.1, x86

User Comments: 
Opening the mercurial module from NetBeans main-golden as a new project.

Stacktrace: 
java.lang.InterruptedException
        at java.lang.Object.wait(Object.java:0)
        at java.lang.Object.wait(Object.java:485)
        at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:244)
        at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:227)
        at org.openide.util.Mutex.readAccess(Mutex.java:327)
        at org.netbeans.api.project.ProjectManager.findProject(ProjectManager.java:227)
Comment 4 smithd1 2009-04-22 13:30:58 UTC
Created attachment 80693 [details]
stacktrace
Comment 5 Milos Kleint 2009-04-23 07:37:58 UTC
looks like that.. I might just revert the interrupting..
Comment 6 _ tboudreau 2009-04-23 14:49:20 UTC
Build: NetBeans IDE Dev (Build 090422)
VM: Java HotSpot(TM) Server VM, 11.0-b15, Java(TM) SE Runtime Environment, 1.6.0_10-b33
OS: Windows XP, 5.1, x86

User Comments: 
Opening java.platform in nbsrc

Stacktrace: 
java.lang.InterruptedException
        at java.lang.Object.wait(Object.java:0)
        at java.lang.Object.wait(Object.java:485)
        at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:244)
        at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:227)
        at org.openide.util.Mutex.readAccess(Mutex.java:327)
        at org.netbeans.api.project.ProjectManager.findProject(ProjectManager.java:227)
Comment 7 _ tboudreau 2009-04-23 14:49:24 UTC
Created attachment 80772 [details]
stacktrace
Comment 8 rajivderas 2009-04-28 15:00:59 UTC
Build: NetBeans IDE 6.7 Beta (Build 200904242137)
VM: OpenJDK Client VM, 14.0-b10, Java(TM) SE Runtime Environment, 1.6.0_14-ea-b01
OS: Windows Vista, 6.0, x86

User Comments: 


Stacktrace: 
java.lang.InterruptedException
        at java.lang.Object.wait(Object.java:0)
        at java.lang.Object.wait(Object.java:485)
        at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:244)
        at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:227)
        at org.openide.util.Mutex.readAccess(Mutex.java:327)
        at org.netbeans.api.project.ProjectManager.findProject(ProjectManager.java:227)
Comment 9 rajivderas 2009-04-28 15:01:09 UTC
Created attachment 81084 [details]
stacktrace
Comment 10 Michal Mocnak 2009-04-29 15:39:24 UTC
Build: NetBeans IDE Dev (Build 200904290201)
VM: Java HotSpot(TM) Client VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Linux, 2.6.26-2-686, i386

User Comments: 


Stacktrace: 
java.lang.InterruptedException
        at java.lang.Object.wait(Object.java:0)
        at java.lang.Object.wait(Object.java:485)
        at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:244)
        at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:227)
        at org.openide.util.Mutex.readAccess(Mutex.java:327)
        at org.netbeans.api.project.ProjectManager.findProject(ProjectManager.java:227)
Comment 11 Michal Mocnak 2009-04-29 15:39:29 UTC
Created attachment 81217 [details]
stacktrace
Comment 12 _ tboudreau 2009-04-29 18:23:00 UTC
Well, the code in question is running inside a Mutex.ExceptionAction;  
                            if (LoadStatus.LOADING_PROJECT.is(o)) {
                                //...
                                } catch (InterruptedException e) {
                                    LOG.log(Level.WARNING, null, e);
                                }
                            }
perhaps this code should throw the exception instead (though the calling code would have to know what to do - I don't
know what the code in the rest of this method does)?
Comment 13 Filip Zamboj 2009-04-30 16:29:53 UTC
Build: NetBeans IDE 6.7 Beta (Build 200904220001)
VM: Java HotSpot(TM) Client VM, 14.0-b12, Java(TM) SE Runtime Environment, 1.6.0_14-ea-b03
OS: Windows Vista, 6.0, x86

User Comments: 
I had debugging session running when I tried to oepn netbeans module on mapped network drive. 

Stacktrace: 
java.lang.InterruptedException
        at java.lang.Object.wait(Object.java:0)
        at java.lang.Object.wait(Object.java:485)
        at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:244)
        at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:227)
        at org.openide.util.Mutex.readAccess(Mutex.java:327)
        at org.netbeans.api.project.ProjectManager.findProject(ProjectManager.java:227)
Comment 14 Filip Zamboj 2009-04-30 16:30:10 UTC
Created attachment 81335 [details]
stacktrace
Comment 15 Erno Mononen 2009-05-05 08:29:25 UTC
Build: NetBeans IDE 6.7 Beta (Build 200904242137)
VM: Java HotSpot(TM) 64-Bit Server VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Linux, 2.6.27-11-generic, amd64

User Comments: 
Thrown while opening an NB module. 

Stacktrace: 
java.lang.InterruptedException
        at java.lang.Object.wait(Object.java:0)
        at java.lang.Object.wait(Object.java:485)
        at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:244)
        at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:227)
        at org.openide.util.Mutex.readAccess(Mutex.java:327)
        at org.netbeans.api.project.ProjectManager.findProject(ProjectManager.java:227)
Comment 16 Erno Mononen 2009-05-05 08:29:31 UTC
Created attachment 81512 [details]
stacktrace
Comment 17 Milos Kleint 2009-05-14 08:02:37 UTC
raising to P2, the obvious solution is to revert changed done with regard to 162612, eg. avoid interrupting the
subproject loading thread in open project wizard.
Comment 18 Vojtech Sigler 2009-05-15 15:45:58 UTC
Build: NetBeans IDE Dev (Build 200905141401)
VM: Java HotSpot(TM) Client VM, 1.5.0_17-b04, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_17-b04
OS: Linux, 2.6.28-11-generic, i386

User Comments: 
I Opened a netbeans module project.

Stacktrace: 
java.lang.InterruptedException
        at java.lang.Object.wait(Object.java:0)
        at java.lang.Object.wait(Object.java:474)
        at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:244)
        at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:227)
        at org.openide.util.Mutex.readAccess(Mutex.java:327)
        at org.netbeans.api.project.ProjectManager.findProject(ProjectManager.java:227)
Comment 19 Vojtech Sigler 2009-05-15 15:46:09 UTC
Created attachment 82200 [details]
stacktrace
Comment 20 Michal Mocnak 2009-05-18 09:46:06 UTC
Build: NetBeans IDE Dev (Build 200905180201)
VM: Java HotSpot(TM) 64-Bit Server VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Linux, 2.6.26-2-amd64, amd64

User Comments: 
Just opening netbeans module -> websphere6

Stacktrace: 
java.lang.InterruptedException
        at java.lang.Object.wait(Object.java:0)
        at java.lang.Object.wait(Object.java:485)
        at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:244)
        at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:227)
        at org.openide.util.Mutex.readAccess(Mutex.java:327)
        at org.netbeans.api.project.ProjectManager.findProject(ProjectManager.java:227)
Comment 21 Michal Mocnak 2009-05-18 09:46:11 UTC
Created attachment 82291 [details]
stacktrace
Comment 22 Filip Zamboj 2009-05-18 14:11:32 UTC
Build: NetBeans IDE Dev (Build 200905180201)
VM: Java HotSpot(TM) 64-Bit Server VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Linux, 2.6.28-11-generic, amd64

User Comments: 
I opened netbeans module php.editor

Stacktrace: 
java.lang.InterruptedException
        at java.lang.Object.wait(Object.java:0)
        at java.lang.Object.wait(Object.java:485)
        at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:244)
        at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:227)
        at org.openide.util.Mutex.readAccess(Mutex.java:327)
        at org.netbeans.api.project.ProjectManager.findProject(ProjectManager.java:227)
Comment 23 Filip Zamboj 2009-05-18 14:11:45 UTC
Created attachment 82312 [details]
stacktrace
Comment 24 Jesse Glick 2009-05-18 20:42:26 UTC
Agreed that it is necessary to revert changes from issue #162612 until a better fix is available.
Comment 25 Michal Mocnak 2009-05-19 22:19:20 UTC
Build: NetBeans IDE Dev (Build 200905190201)
VM: Java HotSpot(TM) 64-Bit Server VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Linux, 2.6.26-2-amd64, amd64

User Comments: 
Opening nb module

Stacktrace: 
java.lang.InterruptedException
        at java.lang.Object.wait(Object.java:0)
        at java.lang.Object.wait(Object.java:485)
        at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:244)
        at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:227)
        at org.openide.util.Mutex.readAccess(Mutex.java:327)
        at org.netbeans.api.project.ProjectManager.findProject(ProjectManager.java:227)
Comment 26 Michal Mocnak 2009-05-19 22:19:30 UTC
Created attachment 82435 [details]
stacktrace
Comment 27 Antonin Nebuzelsky 2009-05-22 13:14:01 UTC
Milos is sick now. Dafe, take care of rolling back the thread interrupting. Needs to be integrated today.
Comment 28 David Simonek 2009-05-22 14:22:39 UTC
anytime my lord :-)
Comment 29 David Simonek 2009-05-22 14:28:09 UTC
calling interrupt of tasks now disallowed:
http://hg.netbeans.org/main/rev/ab21bb9547ff

Jesse please confirm whether I did it right, thank you.
Comment 30 Jesse Glick 2009-05-22 15:43:10 UTC
I'm not sure what ab21bb9547ff was attempting to do, but I think the agreement was to back out the attempted (anyway
failed) fix of issue #162612, i.e. 5cda33da0063.
Comment 31 David Simonek 2009-05-22 21:08:27 UTC
ab21bb9547ff just instructed RequestProcessor to never call interrupt() on thread, which is what we want I think - we
should never get InterruptedException again, so this issue should be fixed. I decided to not rollback whole previous fix
because it introduced some things like lowering thread priority and delaying run of subproject task, which may help a
bit. I hope I'm right...
Comment 32 Quality Engineering 2009-05-23 06:58:07 UTC
Integrated into 'main-golden', will be available in build *200905230201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/ab21bb9547ff
User: Dafe Simonek <dsimonek@netbeans.org>
Log: #163295: Don't allow Thread.interrupt to be called on tasks
Comment 33 mohhmekk 2009-08-13 13:52:22 UTC
Build: NetBeans IDE 6.7.1 (Build 200907230233)
VM: Java HotSpot(TM) Client VM, 14.0-b16, Java(TM) SE Runtime Environment, 1.6.0_14-b08
OS: Linux, 2.6.28-15-generic, i386

User Comments: 


Stacktrace: 
java.lang.InterruptedException
        at java.lang.Object.wait(Object.java:0)
        at java.lang.Object.wait(Object.java:485)
        at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:244)
        at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:227)
        at org.openide.util.Mutex.readAccess(Mutex.java:327)
        at org.netbeans.api.project.ProjectManager.findProject(ProjectManager.java:227)
Comment 34 mohhmekk 2009-08-13 13:52:28 UTC
Created attachment 86197 [details]
stacktrace
Comment 35 Jesse Glick 2010-02-23 16:50:35 UTC
Created attachment 94440 [details]
stacktrace
Comment 36 Jan Lahoda 2010-02-28 12:53:32 UTC
Created attachment 94608 [details]
stacktrace
Comment 37 Jesse Glick 2010-03-01 17:39:02 UTC
Created attachment 94655 [details]
stacktrace
Comment 38 Alexander Simon 2010-03-24 17:50:32 UTC
Created attachment 95714 [details]
stacktrace
Comment 39 Jesse Glick 2010-04-08 21:42:28 UTC
New dupes tracked as bug #174274.