This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 166026 - AssertionError: Should be called from AWT thread
Summary: AssertionError: Should be called from AWT thread
Status: RESOLVED DUPLICATE of bug 90590
Alias: None
Product: platform
Classification: Unclassified
Component: Output Window (show other bugs)
Version: 6.x
Hardware: PC Linux
: P2 blocker with 2 votes (vote)
Assignee: t_h
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-26 12:46 UTC by mgoe
Modified: 2009-05-26 13:23 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mgoe 2009-05-26 12:46:41 UTC
During the start of an application based on the Netbeans platform sometimes the following assertion is thrown:

java.lang.AssertionError: Should be called from AWT thread.
	at org.openide.windows.IOContainer.log(IOContainer.java:346)
	at org.openide.windows.IOContainer.setTitle(IOContainer.java:186)
[catch] at org.netbeans.core.output2.Controller$CoalescedNameUpdater.run(Controller.java:323)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:104)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

I think the reason for this issue is that netbeans pushes a new EventQueue during startup which does not work. Please 
see the discussion for bug 90590.
Comment 1 t_h 2009-05-26 13:23:26 UTC
yes, it is the same issue as issue 90590

*** This issue has been marked as a duplicate of 90590 ***