This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 166387 - NullPointerException at com.sun.tools.javac.comp.Attr.visitSelect
Summary: NullPointerException at com.sun.tools.javac.comp.Attr.visitSelect
Status: RESOLVED DUPLICATE of bug 163989
Alias: None
Product: java
Classification: Unclassified
Component: Compiler (show other bugs)
Version: 6.x
Hardware: All All
: P3 blocker (vote)
Assignee: Dusan Balek
URL: http://statistics.netbeans.org/except...
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-02 10:04 UTC by vshulyak
Modified: 2009-06-18 10:39 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter: 150846


Attachments
stacktrace (3.47 KB, text/plain)
2009-06-02 10:04 UTC, vshulyak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vshulyak 2009-06-02 10:04:16 UTC
Build: NetBeans IDE 6.7 Beta (Build 200904242137)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Linux, 2.6.28-11-generic, i386

User Comments:
vshulyak: I've tried to use autocomplete on generic T type, namely T.class. and after that everything is crashed...



Stacktrace: 
java.lang.NullPointerException
        at com.sun.tools.javac.comp.Attr.visitSelect(Attr.java:1914)
        at com.sun.tools.javac.tree.JCTree$JCFieldAccess.accept(JCTree.java:1655)
        at com.sun.tools.javac.comp.Attr.attribTree(Attr.java:381)
        at com.sun.tools.javac.comp.Attr.attribArgs(Attr.java:442)
        at com.sun.tools.javac.comp.Attr.visitApply(Attr.java:1313)
        at com.sun.tools.javac.tree.JCTree$JCMethodInvocation.accept(JCTree.java:1299)
Comment 1 vshulyak 2009-06-02 10:04:26 UTC
Created attachment 83090 [details]
stacktrace
Comment 2 Dusan Balek 2009-06-18 10:39:22 UTC
Already fixed.

*** This issue has been marked as a duplicate of 163989 ***