This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 168229 - Click Drag / Undo Broken
Summary: Click Drag / Undo Broken
Status: RESOLVED DUPLICATE of bug 60560
Alias: None
Product: editor
Classification: Unclassified
Component: -- Other -- (show other bugs)
Version: 6.x
Hardware: Macintosh All
: P3 blocker (vote)
Assignee: issues@editor
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-07 14:23 UTC by umbra
Modified: 2009-07-23 13:56 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description umbra 2009-07-07 14:23:30 UTC
My first time submitting a bug sorry if there is a problem with the way I do it. Here is my development info

Product Version: NetBeans IDE Dev (Build 200906220201)
Java: 1.5.0_19; Java HotSpot(TM) Client VM 1.5.0_19-137
System: Mac OS X version 10.5.7 running on i386; MacRoman; en_US (nb)
Userdir: /Users/flowers/.netbeans/dev

The problem is when I highlight and drag code, to move it, and then I undo it, it doesn't work the way it should. What happens is it puts the text back to 
where it belongs, but it leaves the copy there. 

When you highlight click drag and release click, I guess it is registering as 2 events, and the undo only "undoes" one of those events. This isn't a major bug 
because, well if you push undo twice your fine, it's just an inconvenience and had me caught up for a while not knowing my error.
Comment 1 Tomasz Slota 2009-07-23 12:55:04 UTC
reproducible in current dev build. The same problem occurs for Java, reassigning to editor
Comment 2 Vitezslav Stejskal 2009-07-23 13:56:27 UTC
Hi, your report is fine, thanks. This was already reported long time ago, but unfortunately has not been fixed yet. As
you said it's not a big problem and so it is a bit low on the priority scale, sorry.

*** This issue has been marked as a duplicate of 60560 ***