Bug 168511 - Can't step through (F7/F8) Java 7 Platform sources with NB 6.7
Summary: Can't step through (F7/F8) Java 7 Platform sources with NB 6.7
Status: CLOSED DUPLICATE of bug 165742
Alias: None
Product: debugger
Classification: Unclassified
Component: Java (show other bugs)
Version: 6.x
Hardware: PC Windows XP
: P3 blocker with 1 vote (vote)
Assignee: issues@debugger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-13 22:40 UTC by wetmore
Modified: 2010-05-06 08:02 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wetmore 2009-07-13 22:40:49 UTC
Melongo Annabel said this may be related to other debugging issues in NB 6.7, but wanted to make sure it was seen.

I hope I got the components/subcomponents right.

========

I develop JDK 7 and generally do so by writing a small test app and set its JDK Platform to my JDK instance under
development.  I've added the platform to NB, added the 5 source directories for it, and all seems to be working fine
with the editor (javadoc and code-completion).

The problem I'm having is stepping through that JDK code.  I set break points in my code (either by line number or by
method name) and the debugger will stop, but then hitting F7/F8 simply restarts the thread and doesn't stop until it
hits another breakpoint.

In NB 6.5, in order to step through the JDK platform sources, you had to go to the debugger source window (alt-shift-8)
and make sure all the corresponding JDK class directories were checked.  Before starting the debugger, they were indeed
all checked.  But immediately after starting the debugger, all 5 JDK source directories disappear from the list, and
only the NB project directory and the src.zip from the JDK that's running NB (in my case:  jdk.1.6.0_14\src.zip, not
JDK7) are listed.  The JDK7 directories are gone: I can hit the breakpoints, but F7/F8 no longer step through the JDK code.

I turned on/off the "step filters" from Tools->Options->Misc->Java Debugger->Step Filters, didn't seem to make a difference.

This works as expected in NB 6.5 and 6.5.1.
Comment 1 wetmore 2009-07-13 22:43:33 UTC
P.S.  It could be related to 165742, but I don't have NB 6.7 installed anymore, I went back to 6.5.1.
Comment 2 Daniel Prusa 2009-07-15 10:56:04 UTC
This could be really related to issue 165742.
However, issue 165742 occurs only if "Compile on Save" project option is enabled. Was it also your case?
[project]->Properties->Build->Compiling->Compile on Save
Comment 3 wetmore 2009-07-15 15:42:56 UTC
Unfortunately, I don't know.  I have already moved back to 6.5.1.

Do you know if "Compile on Save" is the default option in a standard "Java SE" install?
If so, then yes.

I hadn't done any major configuration when I ran into this problem.  I did turn on line numbers
in the editor.
Comment 4 Daniel Prusa 2009-07-15 16:15:25 UTC
Yes, Compile on Save is the default option.
I will mark this issue as a duplicate of 165742. The issue has high priority, we will focus on it.

*** This issue has been marked as a duplicate of 165742 ***
Comment 5 Marian Mirilovic 2010-05-06 08:02:24 UTC
verified duplicate