This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 173405 - [68cat] Variable evaluation does not finish
Summary: [68cat] Variable evaluation does not finish
Alias: None
Product: debugger
Classification: Unclassified
Component: Code (show other bugs)
Version: 6.x
Hardware: PC Windows XP
: P3 blocker (vote)
Assignee: Martin Entlicher
Depends on:
Reported: 2009-09-30 15:24 UTC by ulfzibis
Modified: 2010-05-19 09:31 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:

Evaluating never finishs (151.19 KB, image/png)
2009-09-30 15:26 UTC, ulfzibis
Run test result (99.61 KB, image/png)
2009-10-06 15:04 UTC, ulfzibis
Tried to set Breakpoint (106.74 KB, image/png)
2009-10-06 15:24 UTC, ulfzibis

Note You need to log in before you can comment on or make changes to this bug.
Description ulfzibis 2009-09-30 15:24:46 UTC
[ BUILD # : 3959--090920 ]
[ JDK VERSION : 1.6.* ]

See attachment...
I waited several minutes, and had to stop debug.
Comment 1 ulfzibis 2009-09-30 15:26:46 UTC
Created attachment 88608 [details]
Evaluating never finishs
Comment 2 ulfzibis 2009-09-30 15:46:27 UTC
For reproduce please note comments on, but use jdk1.7.0 as project's JDK.

Use this revision:
Comment 3 ulfzibis 2009-09-30 16:13:38 UTC
Set breakpoint to java.nio.charset.Charset1.lookup() and then advance by Step Over.
Comment 4 Martin Entlicher 2009-10-03 15:41:49 UTC
Unfortunately, I have bug problems to get your program to execute. :-(

After checkout and open of the nio_charset project in NetBeans, I've set JDK 1.7.0 b71 as the project's JDK.
1) I could not build the project, since there is a "resources" folder registered in Sources, which is missing in the
checkout. Therefore I've deleted it from Sources.
2) Which main file should I choose?
3) It looks like whatever main file I choose the program crashes with following exception:
Error occurred during initialization of VM
        at java.util.Hashtable.put(
        at java.lang.System.initProperties(Native Method)
        at java.lang.System.initializeSystemClass(

Java Result: 1

I can execute other projects with JDK 1.7.0 b71 without such error.
Comment 5 Martin Entlicher 2009-10-03 15:53:35 UTC
Do you know what can cause such NPE and how to get rid of it? It's not possible to debug this early stage of VM start. :-(
Which version of JDK 7 do you use?
Comment 6 ulfzibis 2009-10-03 18:18:43 UTC
Oops, first I wanted to say, RTFM, but when I opened, I saw, that the
content of my homepage was completely replaced by default content. Seems that happened when Sun has moved my project to
general tree.

OK, to create the resources you have to set configuration to GenerateCharsetData, run once (CoS=on), (eventually also
Main_sbcs, Main_ext_sbcs) and after return to default configuration.

Hope that helps,
(last post for today)
Comment 7 ulfzibis 2009-10-03 18:19:53 UTC
I used JDK 1.7.0_b72.
Comment 8 ulfzibis 2009-10-05 11:52:06 UTC
I used JDK 1.7.0_b72.
Comment 9 ulfzibis 2009-10-05 11:54:33 UTC
After running CharsetsDataGenerator, Clean&Build the project. This will copy the resources into jar and build folder.
Comment 10 Martin Entlicher 2009-10-06 14:14:48 UTC
I'm sorry, but I still get:

Error occurred during initialization of VM
        at java.util.Hashtable.put(
        at java.lang.System.initProperties(Native Method)
        at java.lang.System.initializeSystemClass(

Java Result: 1
BUILD SUCCESSFUL (total time: 3 seconds)


I use JDK 1.7.0 b71, so I will try with JDK 1.7.0 b72 if it helps...
Comment 11 ulfzibis 2009-10-06 15:02:42 UTC
Maybe important: use Windows XP where Cp1252 is default charset, e.g. German version.
I checked out:
Install ...\Java\jdk1.7.0\fastdebug\ build 72
Open project in NetBeans
Enable CoS + Track Java Dependencies
Set configuration to CharsetsDataGenerator and Run once
Set configuration to default and Clean&Build
Run java.nio.charset.CharsetTest

Comment 12 ulfzibis 2009-10-06 15:04:03 UTC
Created attachment 88910 [details]
Run test result
Comment 13 ulfzibis 2009-10-06 15:24:08 UTC
Created attachment 88916 [details]
Tried to set Breakpoint
Comment 14 ulfzibis 2009-10-06 15:47:00 UTC
Now on Build nbms-and-javadoc-4016-on-090930 Variable evaluation comes to finish, but after long time: ~1 minute.
Comment 15 ulfzibis 2009-10-06 15:50:34 UTC
I set Breakpoint at line 438 in class java.nio.charset.Charset1.
Debug java.nio.charset.CharsetTest.
Comment 16 Martin Entlicher 2009-10-06 16:18:41 UTC
I'm currently trying this on Ubuntu Linux with UTF-8 being the default charset. I'll try with Cp1252 and possibly will
try on Windows... Thanks.
Comment 17 Martin Entlicher 2009-11-16 08:17:08 UTC
It looks like this project is not executable on Linux.
Anyway, on Windows it runs fine, I've run the CharsetTest several times under debugger, with "Static" and "cache" expanded in Variables as it is in the attached screenshot. But unfortunately, it has never happened to me that the debugger would block and Variables would keep showing the Evaluating...

Is this reproducible for you?

It could also be already fixed by some other change, do you have such problems in some recent 6.8 build?

It's important to be reproducible, otherwise even thread dump will not help us to identify the cause.
Comment 18 ulfzibis 2009-11-16 18:42:56 UTC
Seems to work in Build nbms-and-javadoc-4252-on-091109
Comment 19 Marian Mirilovic 2010-05-19 09:31:46 UTC