This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 176140 - Support Groovy in Standard (non Grails) J2EE Webapp
Summary: Support Groovy in Standard (non Grails) J2EE Webapp
Status: RESOLVED DUPLICATE of bug 144038
Alias: None
Product: groovy
Classification: Unclassified
Component: Editor (show other bugs)
Version: 6.x
Hardware: PC Windows Vista
: P1 normal with 1 vote (vote)
Assignee: Martin Janicek
URL:
Keywords:
Depends on: 168944
Blocks:
  Show dependency tree
 
Reported: 2009-11-08 20:58 UTC by nickOathouse
Modified: 2012-08-30 14:57 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nickOathouse 2009-11-08 20:58:33 UTC
Please could you make it so that the behaviour of NetBeans when you add a Groovy class or script to a standard servlet based J2EE webapp is the same as when you add a Groovy class or script to a Java application? ie nbproject includes groovy-build.xml and alterations to project.xml.  This would allow running single scripts and compiling using groovyc.  Thanks.
Comment 1 virvan 2012-04-03 14:31:08 UTC
I second to that. For someone familiar with the IDE codebase it is a 15-minutes task which would make NetBeans much more pleasant to use
Comment 2 Martin Janicek 2012-06-20 15:41:33 UTC
Special groovy-build.xml for web based projects has to be created, GroovyProjectExtender + GroovyActionProvider need to register web-project via @PSP annotation. Build-impl has to be changed in the same way as it is planned for J2SE projects (additional fileset with .class files for running Groovy tests have to be put into the build-impl.xml file)
Comment 3 Martin Janicek 2012-08-30 14:57:48 UTC

*** This bug has been marked as a duplicate of bug 144038 ***