This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 179684 - ${modules.sorted} not defined?
Summary: ${modules.sorted} not defined?
Status: RESOLVED WONTFIX
Alias: None
Product: apisupport
Classification: Unclassified
Component: Harness (show other bugs)
Version: 6.x
Hardware: PC Windows XP
: P3 normal with 1 vote (vote)
Assignee: Jesse Glick
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-19 15:36 UTC by javydreamercsw
Modified: 2010-09-20 19:41 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description javydreamercsw 2010-01-19 15:36:03 UTC
6.8 & Build 201001190201

When trying to compile my Suite I get the following error:

clean:
Z:\Program Files\NetBeans 6.8 Dev\harness\suite.xml:463: Invalid file: Z:\Netbeans\Outlook Interface Tester\OIT\${modules.sorted}
Comment 1 javydreamercsw 2010-01-19 15:44:52 UTC
Using a new project I got this when trying to run the clean target:

Z:\Program Files\NetBeans 6.8 Dev\harness\suite.xml:76: Either cluster.path/cluster.path.evaluated properties or netbeans.dest.dir must be set.
Comment 2 javydreamercsw 2010-01-20 07:40:50 UTC
I had to reinstall Netbeans and checkout my project from version control. Somehow it somehow it seams a nbproject file was either modified or lost somewhere in the process.
Comment 3 Jesse Glick 2010-01-20 09:42:11 UTC
Reopen if you figure out what actually happened and how to reproduce.
Comment 4 tk_fhd_aui 2010-08-28 08:28:59 UTC
Had the same with a module suite. The problem was caused by a missing build.xml in one of it's modules. Workaround possible by clean&build of module.
Tested only on 6.10m1, unsure whether I shall change the version in the issue.
Comment 5 Jesse Glick 2010-09-20 19:41:17 UTC
(In reply to comment #4)
> The problem was caused by a missing build.xml in one of it's modules. 

Then the suite metadata was incomplete; every module must have a build script.

> Tested only on 6.10m1, unsure whether I shall change the version in the issue.

No, Version is the earliest version known to exhibit a bug.