This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 180140 - Function refactoring throws AssertionError at org.netbeans.api.javafx.source.ElementHandle.create
Summary: Function refactoring throws AssertionError at org.netbeans.api.javafx.source....
Status: VERIFIED DUPLICATE of bug 180330
Alias: None
Product: javafx
Classification: Unclassified
Component: Unsupported (show other bugs)
Version: 6.x
Hardware: All All
: P2 normal (vote)
Assignee: J Bachorik
URL:
Keywords:
Depends on:
Blocks: 173077
  Show dependency tree
 
Reported: 2010-02-02 04:14 UTC by Alexandr Scherbatiy
Modified: 2010-02-09 04:38 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter: 164814


Attachments
stacktrace (1.68 KB, text/plain)
2010-02-02 04:14 UTC, Alexandr Scherbatiy
Details
JavaFX project jfx-framework (33.79 KB, application/zip)
2010-02-02 04:17 UTC, Alexandr Scherbatiy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandr Scherbatiy 2010-02-02 04:14:32 UTC
Build: NetBeans IDE Dev (Build 201001280200)
VM: Java HotSpot(TM) Client VM, 14.1-b02, Java(TM) SE Runtime Environment, 1.6.0_15-b03
OS: Windows XP

User Comments:
sunflower: Steps to reproduce:

- Open the attached project
- Open the  jfxframework.ui.AbstractWindow class
- Refactor->Rename the initButtons2 function to initButtons3

The error pops up.




Stacktrace: 
java.lang.AssertionError
   at org.netbeans.api.javafx.source.ElementHandle.create(ElementHandle.java:313)
   at org.netbeans.modules.javafx.refactoring.impl.scanners.BaseRefactoringScanner.<init>(BaseRefactoringScanner.java:69)
   at org.netbeans.modules.javafx.refactoring.impl.plugins.RenameRefactoringPlugin$4.run(RenameRefactoringPlugin.java:394)
   at org.netbeans.modules.javafx.refactoring.impl.plugins.RenameRefactoringPlugin$4.run(RenameRefactoringPlugin.java:391)
   at org.netbeans.modules.javafx.source.parsing.LegacyUserTask.run(LegacyUserTask.java:68)
   at org.netbeans.modules.parsing.api.ParserManager$UserTaskAction.run(ParserManager.java:129)
Comment 1 Alexandr Scherbatiy 2010-02-02 04:14:35 UTC
Created attachment 93752 [details]
stacktrace
Comment 2 Alexandr Scherbatiy 2010-02-02 04:17:31 UTC
Created attachment 93753 [details]
JavaFX project jfx-framework
Comment 3 J Bachorik 2010-02-08 08:41:53 UTC
I believe this is a duplicate of #180330

*** This bug has been marked as a duplicate of bug 180330 ***
Comment 4 Alexandr Scherbatiy 2010-02-09 04:38:39 UTC
verified as duplicate