This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 180534 - Editor points to the end of file after a variable renaming
Summary: Editor points to the end of file after a variable renaming
Status: VERIFIED FIXED
Alias: None
Product: javafx
Classification: Unclassified
Component: Unsupported (show other bugs)
Version: 6.x
Hardware: PC Windows XP
: P3 normal (vote)
Assignee: J Bachorik
URL:
Keywords:
: 181712 (view as bug list)
Depends on:
Blocks: 173077
  Show dependency tree
 
Reported: 2010-02-10 05:52 UTC by Alexandr Scherbatiy
Modified: 2010-03-12 07:00 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandr Scherbatiy 2010-02-10 05:52:46 UTC
NetBeans-JavaFX-Soma:  #148

  Product Version         = NetBeans IDE Dev (Build 201002080200) (#4d6aa72cca05)
  Operating System        = Windows XP version 5.1 running on x86
  Java; VM; Vendor        = 1.6.0_15; Java HotSpot(TM) Client VM 14.1-b02; Sun Microsystems Inc.


Steps to reproduce:

- Create Media Box sample (File-> New Project->Samples->JavaFX)
- Open the com.sun.javafx.mediabox.MediaBox class
- Go to the postinit block
- Refactor->Rename the saved variable to saved2 in the line:
-----------------------------------------
    postinit {
        Timeline {
            repeatCount: Timeline.INDEFINITE
            keyFrames: KeyFrame {
                time: 100ms
                action: function() {
                    var saved = mediaPlayer.balance;

-----------------------------------------

The editor scrolls to the end of file.
Comment 1 J Bachorik 2010-03-09 12:56:23 UTC
*** Bug 181712 has been marked as a duplicate of this bug. ***
Comment 2 J Bachorik 2010-03-11 02:41:13 UTC
http://hg.netbeans.org/javafx/rev/d4c6b66d8b06
Comment 3 Alexandr Scherbatiy 2010-03-12 07:00:55 UTC
verified in NetBeans-JavaFX-Soma: #182