This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 184159 - org.netbeans.modules.apisupport.project.ProjectXMLManager$CyclicDependencyException: Adding project Swing Layout Extensions integration as dependency to DLight THA Monitor would introduce cyclic depen
Summary: org.netbeans.modules.apisupport.project.ProjectXMLManager$CyclicDependencyExc...
Status: RESOLVED DUPLICATE of bug 178584
Alias: None
Product: apisupport
Classification: Unclassified
Component: Project (show other bugs)
Version: 6.x
Hardware: All All
: P3 normal (vote)
Assignee: Jesse Glick
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-14 13:37 UTC by Maria Tishkova
Modified: 2010-04-14 14:14 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter: 168029


Attachments
stacktrace (3.50 KB, text/plain)
2010-04-14 13:37 UTC, Maria Tishkova
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maria Tishkova 2010-04-14 13:37:48 UTC
Build: NetBeans IDE Dev (Build 100405-eb8bfedf9f81)
VM: Java HotSpot(TM) Client VM, 11.0-b15, Java(TM) SE Runtime Environment, 1.6.0_10-b33
OS: SunOS

User Comments:
mromashova: It make impossible to work with the development versio!!!




Stacktrace: 
org.netbeans.modules.apisupport.project.ProjectXMLManager$CyclicDependencyException: Adding project Swing Layout Extensions integration as dependency to DLight THA Monitor would introduce cyclic dependency! Dependency was not added.
   at org.netbeans.modules.apisupport.project.ProjectXMLManager.replaceDependencies(ProjectXMLManager.java:430)
   at org.netbeans.modules.apisupport.project.ui.customizer.SingleModuleProperties.storeProperties(SingleModuleProperties.java:912)
   at org.netbeans.modules.apisupport.project.ui.customizer.CustomizerProviderImpl.storeProperties(CustomizerProviderImpl.java:87)
   at org.netbeans.modules.apisupport.project.ui.customizer.BasicCustomizer$1.run(BasicCustomizer.java:159)
   at org.netbeans.modules.apisupport.project.ui.customizer.BasicCustomizer$1.run(BasicCustomizer.java:157)
   at org.openide.util.Mutex.writeAccess(Mutex.java:433)
Comment 1 Maria Tishkova 2010-04-14 13:37:52 UTC
Created attachment 97336 [details]
stacktrace
Comment 2 Jesse Glick 2010-04-14 14:14:36 UTC
Get a newer dev build.

*** This bug has been marked as a duplicate of bug 178584 ***